summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-20 23:27:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-20 23:28:24 +0300
commit18f1b7fd1b59bbbb6fe212a9ecb2a2121224b03c (patch)
treef36885abe60c4b514d0e88c508782ee3f1113b68 /gui-libs
parentapp-misc/resolve-march-native: 5.1.0 with SSE4 fixes (diff)
downloadgentoo-18f1b7fd1b59bbbb6fe212a9ecb2a2121224b03c.tar.gz
gentoo-18f1b7fd1b59bbbb6fe212a9ecb2a2121224b03c.tar.bz2
gentoo-18f1b7fd1b59bbbb6fe212a9ecb2a2121224b03c.zip
gui-libs/wlroots: add 0.18.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.18.1.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index e749afe959c7..b7afa43d2aa9 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,2 +1,3 @@
DIST wlroots-0.17.4.tar.gz 609179 BLAKE2B dc5a7749533ab54631d4a26be554b86e5b08b2472cf8f22ccebddb319d571cbd98a5c56e64e7bc762a5918d4272eb6b4261050288f3053c18c824c6a9c32b96b SHA512 35803df9fe68cadb0b9b5e522863535407ba2354ed1ca8f824a9c40b64698a97c579fec0afeb444b05d429adc1e3dfc45b20c3a1b7a2004e4f5a10d2305c9116
DIST wlroots-0.18.0.tar.gz 628190 BLAKE2B b1d725e0397365b69afce24baf5376057a40d225f7cb06ccd5abde3b3da8d5401a6eb5d57ab65154a6faf7961473039833e558e3b25da1210891d34667da5bf9 SHA512 2cf848aa67f41089b60cc7d01c3a344ebaf7f5bbced459675fef885cd4b3e6b99d9a49d6b127518314d0ae38e52e9aff7991611592b2add4cba96f15aa0bf1c6
+DIST wlroots-0.18.1.tar.gz 628648 BLAKE2B 051909ef4cac4c523bb43b42396abe8c18e3835a7a29bde30787829040271720f06579dadf3f03d9569bcc1e25492c6bd383f314aaa10b63c597f08735d30537 SHA512 c4d83ae75aec4f7f4e8aefbff27594d0962c56c4a3a3ef2d7ccd432f92eb56df7edb995cc0fa1f62d9290e988f20e7525d007717f36ce4824dfc41061a697fbb
diff --git a/gui-libs/wlroots/wlroots-0.18.1.ebuild b/gui-libs/wlroots/wlroots-0.18.1.ebuild
new file mode 100644
index 000000000000..c10dc7018f2a
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.18.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+ SLOT="0.18"
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/releases/${PV}/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SLOT="$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="liftoff +libinput +drm +session lcms vulkan x11-backend xcb-errors X"
+REQUIRED_USE="
+ drm? ( session )
+ lcms? ( vulkan )
+ libinput? ( session )
+ liftoff? ( drm )
+ xcb-errors? ( || ( x11-backend X ) )
+"
+
+DEPEND="
+ >=dev-libs/wayland-1.23.0
+ media-libs/libglvnd
+ || (
+ >=media-libs/mesa-24.1.0_rc1[opengl]
+ <media-libs/mesa-24.1.0_rc1[egl(+),gles2]
+ )
+ >=x11-libs/libdrm-2.4.122
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ drm? (
+ media-libs/libdisplay-info:=
+ sys-apps/hwdata
+ liftoff? ( >=dev-libs/libliftoff-0.4 )
+ )
+ lcms? ( media-libs/lcms:2 )
+ libinput? ( >=dev-libs/libinput-1.19.0:= )
+ session? (
+ sys-auth/seatd:=
+ virtual/libudev
+ )
+ vulkan? (
+ dev-util/glslang:=
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ )
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ x11-backend? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-renderutil
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ x11-base/xwayland
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.35
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local backends=(
+ $(usev drm)
+ $(usev libinput)
+ $(usev x11-backend 'x11')
+ )
+ local meson_backends=$(IFS=','; echo "${backends[*]}")
+ local emesonargs=(
+ $(meson_feature xcb-errors)
+ -Dexamples=false
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ $(meson_feature X xwayland)
+ -Dbackends=${meson_backends}
+ $(meson_feature session)
+ $(meson_feature lcms color-management)
+ $(meson_feature liftoff libliftoff)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc docs/*
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}