summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-04 11:08:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-04 22:27:44 +0100
commit424185f3c9a13014fc6cc54832a5c51d8579e1b4 (patch)
tree30731e196d7162f0251afe5c8fef4ccf5c99590e /kde-apps/akonadi-contacts/akonadi-contacts-20.12.3.ebuild
parentkde-apps/akonadi-calendar: 20.12.3 version bump (diff)
downloadgentoo-424185f3c9a13014fc6cc54832a5c51d8579e1b4.tar.gz
gentoo-424185f3c9a13014fc6cc54832a5c51d8579e1b4.tar.bz2
gentoo-424185f3c9a13014fc6cc54832a5c51d8579e1b4.zip
kde-apps/akonadi-contacts: 20.12.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi-contacts/akonadi-contacts-20.12.3.ebuild')
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-20.12.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-20.12.3.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-20.12.3.ebuild
new file mode 100644
index 000000000000..b546743d414b
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-20.12.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for akonadi contact integration"
+
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="GPL-2+"
+IUSE=""
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-libs/grantlee-5.2.0:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/grantleetheme-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"