summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-18 15:42:18 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-18 16:03:33 +0200
commit66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd (patch)
tree5096e0b3a3b9501276d23ccbdefa39f613d758d5 /kde-apps/kdebase-data/kdebase-data-16.04.1.ebuild
parentapp-misc/tmux: Add 2.1-r1 and ship terminfo file. (diff)
downloadgentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.tar.gz
gentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.tar.bz2
gentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.zip
kde-apps: Version bump KDE Applications 16.04.1
Except KDE PIM which is not ready for production yet, which is available (masked) in kde overlay. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'kde-apps/kdebase-data/kdebase-data-16.04.1.ebuild')
-rw-r--r--kde-apps/kdebase-data/kdebase-data-16.04.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/kdebase-data/kdebase-data-16.04.1.ebuild b/kde-apps/kdebase-data/kdebase-data-16.04.1.ebuild
new file mode 100644
index 000000000000..f9a1d7e90edc
--- /dev/null
+++ b/kde-apps/kdebase-data/kdebase-data-16.04.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase"
+IUSE="+wallpapers"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-themes/hicolor-icon-theme
+ wallpapers? ( || ( $(add_kdeapps_dep kde-wallpapers '' 15.08.3) kde-apps/kde-wallpapers:5 ) )
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}