summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:01:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:19:52 +0200
commit9575324283ad2babba8b22185b5255376b8c686b (patch)
tree1d5567c892d13a113f6d6e7ab923fe3a0c37ba13 /kde-apps/kolourpaint
parentmedia-gfx/krita: 4.1.4 version bump (diff)
downloadgentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.gz
gentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.bz2
gentoo-9575324283ad2babba8b22185b5255376b8c686b.zip
kde-apps: Add KDE Applications 18.08.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-18.08.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index caa80939354d..8b474d1418a0 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1,2 +1,3 @@
DIST kolourpaint-18.04.3.tar.xz 5548984 BLAKE2B 15017e7bfe7b7a8c82f0340f3cd4e222f3871f476f2530df358ca65e0f1971ec85199f2ed67e1a86a998331b4a5bec1e3ba1ec0b4ad5ef8d3d1c949ea074c216 SHA512 e9e90e16ac93f019327f9987f546ea55999a707e5ac93218a6850669bd729506d80c52e2e1cdc78d5c2d12a3abc696412c7eee07343a2bf726d7c5fadb5ff4e0
DIST kolourpaint-18.08.1.tar.xz 5548748 BLAKE2B 19e6e074492e801d91352319a47b3e4730373508fc315007e0a76507826606a1e66fc2804e7856b829af4d549e2e8f3eb911aa05bf547ccac2462469300cab6f SHA512 ffd286a272bb0152238f73ab510d9eab006b9362f1d4d4f35b30d3ba9d3335be24f86b6aa71e29a5c5faf87c6d72e96f58ff2b0fbcbcaf1471c94a9fff8949c0
+DIST kolourpaint-18.08.2.tar.xz 5548524 BLAKE2B 6bd80d4740fa9830949f6bb55f69e04e8fbf34f57c249c7b7c6272d85def63475fb1ff1487f3fede5126f45d0a010c3eded04e3ff30aca5a3f977def2a39a6fa SHA512 ccfee1869ada8b61c20e9df322e0811a26f19d028be6f7895cf517c109ae00d72622032ce1117aa2b1573c5c333e63d70f4f444c1c627a4dbc11c499eec934fe
diff --git a/kde-apps/kolourpaint/kolourpaint-18.08.2.ebuild b/kde-apps/kolourpaint/kolourpaint-18.08.2.ebuild
new file mode 100644
index 000000000000..cce9441c5950
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-18.08.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://www.kde.org/applications/graphics/kolourpaint/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+IUSE="scanner"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}