summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-03 18:58:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-04 13:50:37 +0200
commitac7e36399d30d0ccb29ecb14dae44bc1f65525a8 (patch)
tree6a8675bf4d438018c454e0681b8eac294d6f8202 /kde-apps/pimcommon
parentkde-apps/pim-sieve-editor: 24.05.2 version bump (diff)
downloadgentoo-ac7e36399d30d0ccb29ecb14dae44bc1f65525a8.tar.gz
gentoo-ac7e36399d30d0ccb29ecb14dae44bc1f65525a8.tar.bz2
gentoo-ac7e36399d30d0ccb29ecb14dae44bc1f65525a8.zip
kde-apps/pimcommon: 24.05.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-24.05.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 5e677dfe695f..d0b9abd27925 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-23.08.5.tar.xz 349196 BLAKE2B 66d525d68108ecba772cb4f145da893a3f739f3729cd458c62fcc4affaaed8776a4dc558db25fb86597e0842738f2820af622efe6c24e4ed344d43477d5795db SHA512 36464dc23f601d7ffb4cd85be9bc48c15bf610b59de635664ba01d50c914e58ce78c66f0ba33c4db245fd063d721b7b918fd39ab0e466a307a52f7b32d627ae3
DIST pimcommon-24.05.1.tar.xz 349660 BLAKE2B 8d7d3ebd66ac5ff4826ddafe073594e9409d4375c99ddc984a8cabacff2b1a400f6495494d0e28d9baf45c1ca9c91429c0c428063b8fb889c8e0b787adeac2e9 SHA512 576e5abdd635fd432ecf441bbb62519b5de3b99a2ea503d3b4fc751750cb3b0d284fea448f59de37487bd772b1a0469d05d5c84c8baa5f4a8bd2776f58c6eff9
+DIST pimcommon-24.05.2.tar.xz 349596 BLAKE2B 5b000afc625f26219fb03360d4e26ba14ef34de3a186e1003abacd479aa822f72439ec055612013fa2714f285d6b1f1fe739c498fb73ec4e5200ff92aeece469 SHA512 626799e69cc12d9d53cd8754e9dc8899729d50d340a3bc4cee44ebf145d83451fb5f2ac5af85621123318784c1cc5da7a6c207f53e5eb7ce91cfd4a022d01135
diff --git a/kde-apps/pimcommon/pimcommon-24.05.2.ebuild b/kde-apps/pimcommon/pimcommon-24.05.2.ebuild
new file mode 100644
index 000000000000..c01e4ab52616
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-24.05.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_QTHELP="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Common PIM libraries"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/ktextaddons-1.5.4:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets,xml]
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/akonadi-search-${PVCUT}:6
+ >=kde-apps/kimap-${PVCUT}:6
+ >=kde-apps/kldap-${PVCUT}:6
+ >=kde-apps/libkdepim-${PVCUT}:6
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcodecs-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knewstuff-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatorwidgettest)"
+ )
+
+ ecm_src_test
+}