summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-10 21:19:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:14 +0200
commita7030fcd38880ac327f749bb528f65a0a4ee7ae7 (patch)
tree08ecff369172b6779cc7b6295ff2f1a069b73859 /kde-frameworks/frameworkintegration
parentapp-office/kraft: Accept kde-frameworks/kcontacts (diff)
downloadgentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.tar.gz
gentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.tar.bz2
gentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.zip
kde-frameworks: Add KDE Frameworks 5.63.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.63.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index b1d6123c8a8f..08057c7baa81 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.60.0.tar.xz 1753424 BLAKE2B f0752ba701ad1bc3c447f1d7c17ab22b922efc570bf6ef84c51ef58ee9e3f32f68f0ef222c88991252db60a0b0e63cdec672b20b693807d50b3bed2b1b7c95b3 SHA512 4313e31789046e49d644a8613c0274c44f15ce7bfdee1e66240a1cbf6c625eba093fa0a2d922833a336c208aa75af8c949d0881bd17efe2c1007045d3a9288a5
DIST frameworkintegration-5.62.0.tar.xz 1754660 BLAKE2B ffb435d47c9e006f62be2c64caf69ef1c6aed97f47223a6e8ee29c0ac101c628e880f202ccfcd66f285d24749a675bc922dc59f240e4825ed2f0c9f86b25d9d9 SHA512 918ecb9ddf50cfa8b8fce3fb218a8b80a97d3e440e3c6faf5bb76e74ff1752448244da19da0367a6e077ee8f7e4599328da667d63d45c35490a0a7436570e336
+DIST frameworkintegration-5.63.0.tar.xz 1754592 BLAKE2B 68000a87f67cc92704f349ec03e33bba9c9677e25210e42d6eb3e50ff825e593cf3b6c08fc22ee3db6562b93a9d9c495a22189bb6e3076a2b4d62ae37373bea0 SHA512 76edf9191fad80c19f5bc2bc40e91b16583219bf4dd79c0a722089195ef0325f95a6863723cbc7e1c46446d978ff812ce13afb78bd47fc0b96e0fe26f8716ea4
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.63.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.63.0.ebuild
new file mode 100644
index 000000000000..abb6426a7b47
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.63.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}