summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-08 23:50:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-09 17:49:59 +0100
commit92ce08d47d7105b5d7a8c7140798a277b9b844ea (patch)
tree41bca5c9474de6cec35e12d8490260764da53970 /kde-frameworks/kpeople/kpeople-5.53.0.ebuild
parentkde5-functions: Raise QT_MINIMAL to 5.11.1 (diff)
downloadgentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.tar.gz
gentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.tar.bz2
gentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.zip
kde-frameworks: Add KDE Frameworks 5.53.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpeople/kpeople-5.53.0.ebuild')
-rw-r--r--kde-frameworks/kpeople/kpeople-5.53.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/kpeople-5.53.0.ebuild b/kde-frameworks/kpeople/kpeople-5.53.0.ebuild
new file mode 100644
index 000000000000..a25b7fe58e9a
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-5.53.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://cgit.kde.org/kpeople.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !net-libs/kpeople:5
+"
+
+src_test() {
+ # personsmodeltest segfaults, bug 668192
+ local myctestargs=(
+ -j1
+ -E "(persondatatest)"
+ )
+
+ kde5_src_test
+}