summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-08 15:25:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-08 15:38:02 +0100
commit8abcab724de27bf3ac55160f112e9337ff43fae1 (patch)
tree75f2b36811edb67c32e60c9e46cec20ecf5bbc1e /kde-frameworks/kquickcharts
parentkde-frameworks/kplotting: 6.8.0 version bump (diff)
downloadgentoo-8abcab724de27bf3ac55160f112e9337ff43fae1.tar.gz
gentoo-8abcab724de27bf3ac55160f112e9337ff43fae1.tar.bz2
gentoo-8abcab724de27bf3ac55160f112e9337ff43fae1.zip
kde-frameworks/kquickcharts: 6.8.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts')
-rw-r--r--kde-frameworks/kquickcharts/Manifest1
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-6.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/Manifest b/kde-frameworks/kquickcharts/Manifest
index 4c9db9269e75..b2aa16c7c97d 100644
--- a/kde-frameworks/kquickcharts/Manifest
+++ b/kde-frameworks/kquickcharts/Manifest
@@ -1,2 +1,3 @@
DIST kquickcharts-6.6.0.tar.xz 110208 BLAKE2B 43af5f0604e2313cd8494d924caeacf233402898e56d3e6dc048b3866fed28811da4270ac9a6bf1bade9fb03abcca8d66a6ebacd3d8b09c9e20f49729e309924 SHA512 fe9b8441ece209eb5c7b4a3675c148739ce2cbd799ce976c46f9a45c39d4acb9b195dddad25ac57cd164cebb75964c17ae097671841b3fddf6879b45cfc630e0
DIST kquickcharts-6.7.0.tar.xz 110180 BLAKE2B bdc75fe0d872336d6617837acf385fd528e614904cd96727f86a9bf332164a3b9ec85d90b85e7006e4c4855b451cdbadab852c322283edf8fad799be6eddc998 SHA512 3a1bfe21b07f510c71947bf8bdf627baa4032dc7d3b31a7501cf2f52cc608796ef4cd249514dd859ae50bbcab7d1a43b63328cdd3ab7ecee82e3ad8a5e273ca7
+DIST kquickcharts-6.8.0.tar.xz 110308 BLAKE2B 56e1c526a25b81e9d1cd0c87670c83f90474df04a5625e6eb06f71e3b3c6e14421aed170c6a8607edb34828fe457115487d4bfe1f5c5b8ba595f59b9ab09d5c4 SHA512 d1713822bdcb85f1dd2545493268eb6a2160010fcfe17c06463e90ecb8f2fdc5d83176f54b6f6c0429550725bb8d76a62a674f52a2f642a8e6dbd4b43aa20120
diff --git a/kde-frameworks/kquickcharts/kquickcharts-6.8.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-6.8.0.ebuild
new file mode 100644
index 000000000000..6189c92822db
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-6.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.7.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtshadertools-${QTMIN}:6
+ examples? (
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ =kde-frameworks/kdeclarative-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ )
+"
+RDEPEND="${DEPEND}
+ examples? ( !${CATEGORY}/${PN}:5[examples(-)] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}