summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-17 22:13:25 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-17 22:13:47 +1100
commitf640b7c3b14c747f026e5667beddbf7def4d0549 (patch)
treedae4cf06bb5cb43ae72c348db93484786451dcd9 /kde-frameworks/plasma
parentprofiles: dev-util/eclipse-sdk has been removed (diff)
downloadgentoo-f640b7c3b14c747f026e5667beddbf7def4d0549.tar.gz
gentoo-f640b7c3b14c747f026e5667beddbf7def4d0549.tar.bz2
gentoo-f640b7c3b14c747f026e5667beddbf7def4d0549.zip
kde-frameworks/plasma: backport two patches from upstream
Solves a crash when diplaying tooltips in the task manager, and missing icons in the system tray. Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.19.0-crash.patch27
-rw-r--r--kde-frameworks/plasma/files/plasma-5.19.0-systrayicons.patch34
-rw-r--r--kde-frameworks/plasma/plasma-5.19.0-r1.ebuild75
3 files changed, 136 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.19.0-crash.patch b/kde-frameworks/plasma/files/plasma-5.19.0-crash.patch
new file mode 100644
index 000000000000..8c3a60bf6d38
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.19.0-crash.patch
@@ -0,0 +1,27 @@
+From 1e196fdfb2a6eaf1664e1155c086616d55c6712b Mon Sep 17 00:00:00 2001
+From: David Rosca <nowrep@gmail.com>
+Date: Mon, 15 Feb 2016 19:05:26 +0100
+Subject: [PATCH] WindowThumbnail: Discard glx pixmap in stopRedirecting()
+
+BUG: 357895
+FIXED-IN: 5.20
+REVIEW: 127072
+---
+ src/declarativeimports/core/windowthumbnail.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/declarativeimports/core/windowthumbnail.cpp b/src/declarativeimports/core/windowthumbnail.cpp
+index 21e655e..b838053 100644
+--- a/src/declarativeimports/core/windowthumbnail.cpp
++++ b/src/declarativeimports/core/windowthumbnail.cpp
+@@ -584,6 +584,7 @@ void WindowThumbnail::stopRedirecting()
+ return;
+ }
+ xcb_composite_unredirect_window(c, m_winId, XCB_COMPOSITE_REDIRECT_AUTOMATIC);
++ discardPixmap();
+ if (m_damage == XCB_NONE) {
+ return;
+ }
+--
+2.4.10
+
diff --git a/kde-frameworks/plasma/files/plasma-5.19.0-systrayicons.patch b/kde-frameworks/plasma/files/plasma-5.19.0-systrayicons.patch
new file mode 100644
index 000000000000..f8488cfe071d
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.19.0-systrayicons.patch
@@ -0,0 +1,34 @@
+From 525bf2d377c21b41971a72d694a507bf2af0ada6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Dan=20Vr=C3=A1til?= <dvratil@kde.org>
+Date: Tue, 16 Feb 2016 17:59:32 +0100
+Subject: [PATCH] Fix IconItem not loading non-theme icons with name
+
+Commit 5184ac introduced a small regression that caused IconItem
+to no longer load non-theme icons with name set, for instance icons
+coming from sni-qt, causing sni-qt apps to not show in systray.
+
+BUG: 359388
+FIXED-IN: 5.20
+REVIEW: 127091
+---
+ src/declarativeimports/core/iconitem.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/declarativeimports/core/iconitem.cpp b/src/declarativeimports/core/iconitem.cpp
+index 1d7921a..085f284 100644
+--- a/src/declarativeimports/core/iconitem.cpp
++++ b/src/declarativeimports/core/iconitem.cpp
+@@ -148,6 +148,10 @@ void IconItem::setSource(const QVariant &source)
+ //fail, use QIcon
+ } else {
+ m_icon = QIcon::fromTheme(sourceString);
++ if (m_icon.isNull()) {
++ // fallback for non-theme icons
++ m_icon = source.value<QIcon>();
++ }
+ delete m_svgIcon;
+ m_svgIcon = 0;
+ m_imageIcon = QImage();
+--
+2.4.10
+
diff --git a/kde-frameworks/plasma/plasma-5.19.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.19.0-r1.ebuild
new file mode 100644
index 000000000000..dae680851966
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.19.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KMNAME="${PN}-framework"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma framework"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="egl gles2 X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui 'gles2=')
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ egl? ( media-libs/mesa[egl] )
+ !gles2? ( virtual/opengl )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kdoctools)
+ X? ( x11-proto/xproto )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-apps/kapptemplate-15.08.3-r1:5
+ !<kde-plasma/kdeplasma-addons-5.4.3-r1
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-crash.patch"
+ "${FILESDIR}/${P}-systrayicons.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package !gles2 OpenGL)
+ $(cmake-utils_use_find_package X X11)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}