summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 13:36:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 15:16:36 +0100
commitdc3b84c72d0db096475a3ef28724fc8ccf30c8e3 (patch)
treeca4f50a6229de73854afc7380085e7e481a790a3 /kde-frameworks/sonnet
parentkde-frameworks/solid: 5.100.0 version bump (diff)
downloadgentoo-dc3b84c72d0db096475a3ef28724fc8ccf30c8e3.tar.gz
gentoo-dc3b84c72d0db096475a3ef28724fc8ccf30c8e3.tar.bz2
gentoo-dc3b84c72d0db096475a3ef28724fc8ccf30c8e3.zip
kde-frameworks/sonnet: 5.100.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.100.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 43be0aa69854..2aab0deafd89 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
+DIST sonnet-5.100.0.tar.xz 2463748 BLAKE2B 1a050aa64121438390a0e617f48ec7813955c703c5902331c26c73fff6e112b41886a92720b69970074ea81f9d23fad4cc4e39eca462fc515a31b893ae1d80f7 SHA512 760a95122f41da4ac8842d1869d96d1fd6ae2d92a93e33c89088fee08050b7bd5f9e4668987d47c86556281f97f54d8b13973e18629cde7af13cf1a0b9510cb8
DIST sonnet-5.96.0.tar.xz 308092 BLAKE2B 89c568becffb3a13f7583e6e34e6e2046715f1abf906c9cda60ad8c14723b4b0c0330c25172a233067deea09f4e687d5afb8f357ffd9536adb392275697c4173 SHA512 4625328b255112fd6d727db8e91d47b9fd45ab9b19a754dc6bee0de96a1002a9e812c7de0ddfdb4c146581192f8a36e1a274903d7525b6a0541e6bcf2641f6f9
DIST sonnet-5.99.0.tar.xz 307868 BLAKE2B 43591a0bd09f88b745b8577a8ac38b6fc1a60a20f97e2d35de19072f7956fd31974d35ebdbd3a802b4b0c7c63bfdacc214314e43dc3d0655c59a9df4236df6a1 SHA512 781e96a9ff4363dd4bc2a95f6fadcd97991cbcd4781314f082297544c4da38c57fa62c4aec62d8cf850c5d8147e0b30f6835d143a691ea293100c00511ab318b
diff --git a/kde-frameworks/sonnet/sonnet-5.100.0.ebuild b/kde-frameworks/sonnet/sonnet-5.100.0.ebuild
new file mode 100644
index 000000000000..6a624120445d
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.100.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="aspell +hunspell nls qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ -DSONNET_USE_QML=$(usex qml)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # sonnet-test_settings: bug 680032
+ # sonnet-test_autodetect: bug 779994
+ local myctestargs=(
+ -E "(sonnet-test_autodetect|sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}