summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/tellico
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/tellico')
-rw-r--r--kde-misc/tellico/Manifest1
-rw-r--r--kde-misc/tellico/metadata.xml14
-rw-r--r--kde-misc/tellico/tellico-2.3.10.ebuild62
3 files changed, 77 insertions, 0 deletions
diff --git a/kde-misc/tellico/Manifest b/kde-misc/tellico/Manifest
new file mode 100644
index 000000000000..c1c242bcfa8f
--- /dev/null
+++ b/kde-misc/tellico/Manifest
@@ -0,0 +1 @@
+DIST tellico-2.3.10.tar.bz2 4877384 SHA256 e916101f86b6f843b85be42e8545aa7441cd496cbb9b81590e2e0bd03a58faaa SHA512 a93300900febae996633294fa0b2e5808af62bbebafa718e0ba345f206dcd2836e44b6172621fd1b506fd3e6ae60f5c03514d0f53433188c67e6b92a058b33aa WHIRLPOOL 88ea79b081ae35a6f4bff5a34d9df2e2e85af2435e071d93697d4157e8aff638c881445bfa0f9f1bcf30807ac30280e39f08cbc4c968aee47b963b6447f65bb3
diff --git a/kde-misc/tellico/metadata.xml b/kde-misc/tellico/metadata.xml
new file mode 100644
index 000000000000..f2d71d903093
--- /dev/null
+++ b/kde-misc/tellico/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <longdescription lang="en">
+ Tellico is a KDE application for organizing your collections. It provides
+ default templates for books, bibliographies, videos, music, video games, coins,
+ stamps, trading cards, comic books, and wines.
+ </longdescription>
+ <use>
+ <flag name="addressbook">Add support for kdepim addressbook (kabc)</flag>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ </use>
+</pkgmetadata>
diff --git a/kde-misc/tellico/tellico-2.3.10.ebuild b/kde-misc/tellico/tellico-2.3.10.ebuild
new file mode 100644
index 000000000000..e7cad208526f
--- /dev/null
+++ b/kde-misc/tellico/tellico-2.3.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fi fr ga gl hu
+ia it ja kk lt mr ms nb nds nl nn pl pt pt_BR ro ru sk sl sv tr ug uk zh_CN
+zh_TW"
+KDE_MINIMAL="4.13.1"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A collection manager for the KDE environment"
+HOMEPAGE="http://tellico-project.org/"
+SRC_URI="http://tellico-project.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="addressbook cddb debug nepomuk pdf scanner taglib v4l xmp yaz"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qjson
+ dev-qt/qtdbus:4
+ media-libs/qimageblitz
+ addressbook? ( $(add_kdebase_dep kdepimlibs) )
+ cddb? ( $(add_kdeapps_dep libkcddb) )
+ nepomuk? ( $(add_kdebase_dep kdelibs 'nepomuk?') )
+ pdf? ( app-text/poppler[qt4] )
+ scanner? ( $(add_kdeapps_dep libksane) )
+ taglib? ( >=media-libs/taglib-1.5 )
+ v4l? ( >=media-libs/libv4l-0.8.3 )
+ xmp? ( >=media-libs/exempi-2 )
+ yaz? ( >=dev-libs/yaz-2 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+# tests need network access and well-defined server responses
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with addressbook KdepimLibs)
+ $(cmake-utils_use_with cddb KdeMultimedia)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with scanner KSane)
+ $(cmake-utils_use_with taglib)
+ $(cmake-utils_use_enable v4l WEBCAM)
+ $(cmake-utils_use_with xmp Exempi)
+ $(cmake-utils_use_with yaz)
+ )
+
+ kde4-base_src_configure
+}