summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 20:21:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 23:05:24 +0200
commit55391d594cbb90254c591743415442484c3b0d02 (patch)
tree0495277eae519b0471a036e40a57ebd77d661530 /kde-plasma/drkonqi
parentdev-python/pillow: bump to 6.0.0 (diff)
downloadgentoo-55391d594cbb90254c591743415442484c3b0d02.tar.gz
gentoo-55391d594cbb90254c591743415442484c3b0d02.tar.bz2
gentoo-55391d594cbb90254c591743415442484c3b0d02.zip
kde-plasma: Add KDE Plasma 5.15.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/drkonqi')
-rw-r--r--kde-plasma/drkonqi/Manifest1
-rw-r--r--kde-plasma/drkonqi/drkonqi-5.15.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/drkonqi/Manifest b/kde-plasma/drkonqi/Manifest
index 1ea87848bb64..395603ff915d 100644
--- a/kde-plasma/drkonqi/Manifest
+++ b/kde-plasma/drkonqi/Manifest
@@ -1,2 +1,3 @@
DIST drkonqi-5.14.5.tar.xz 737580 BLAKE2B 1bb0ee7a70df8740feb6838bae7679c4acff4bf976e85a733da102db9716efcee5fd4f314f3877607ce600123b6452694a8fa528ea87a41f49d76b3bdb46f975 SHA512 8985ab8fae82e16fce6d604fcf6e4a393e1a147061f09eaaca6cd048fe9cba47cc9959013fc912b3829a9aaf3c471941597c5d1d3630f243fa1871e387757b36
DIST drkonqi-5.15.3.tar.xz 738680 BLAKE2B 73407d179e45ec37eca802755333acd19a58bcf7236519b4af3f2d45baa8acc66b20273b0461916a10719a6adb638adc0ff61f9bfc1f9dfcc912ad8a1f8148ce SHA512 64cc9c3ff39aee2cf5ed289e469a7befda1d3fd5f8f9f2e790227c0bfe979d8bebe0546ce822bb7c68a28738c7762aa13b4f5f7db816eb601b5715b3991c83ec
+DIST drkonqi-5.15.4.tar.xz 738768 BLAKE2B a76d500ba12ce01c83758441d968fe79fe507ca83ab2787941d1105ada88e9f599858565abe730b96f9a2795bc57b14bf18614b1d3e3c85de5c340cdc927b185 SHA512 49e71e883bcf805444f66beb579cdbd371d3cb9780d485b89ae2e75e1094b89d5182ac9351fa739375c519dc28e4a66f22af081c5e5336e01ab61a628aa7b692
diff --git a/kde-plasma/drkonqi/drkonqi-5.15.4.ebuild b/kde-plasma/drkonqi/drkonqi-5.15.4.ebuild
new file mode 100644
index 000000000000..8dbc6989fc44
--- /dev/null
+++ b/kde-plasma/drkonqi/drkonqi-5.15.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Plasma crash handler, gives the user feedback if a program crashed"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlrpcclient)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-plasma/plasma-workspace-5.10.95:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X Qt5X11Extras)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ if ! has_version "sys-devel/gdb"; then
+ elog "For more usability consider installing the following package:"
+ elog " sys-devel/gdb - Easier debugging support"
+ fi
+}