summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 09:58:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 11:22:23 +0100
commit3c53c85d14bb628506df989f6bc590ad98c88c16 (patch)
treebdad2ef8d4660aa208b3fb7388f284aba52c2e77 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.27.1 version bump (diff)
downloadgentoo-3c53c85d14bb628506df989f6bc590ad98c88c16.tar.gz
gentoo-3c53c85d14bb628506df989f6bc590ad98c88c16.tar.bz2
gentoo-3c53c85d14bb628506df989f6bc590ad98c88c16.zip
kde-plasma/kinfocenter: 5.27.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.27.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index a38bf33bffee..a2edf8b815f1 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.26.5.tar.xz 736144 BLAKE2B 1e6f6bc3abc78c1cfc6564b48fb9101158965b3aba029bd138d5f885163ebbaafaf6386c3a759ef67d8007844d1cc07a4c7191cc179b175ef99ca3f1e21fa8b1 SHA512 a00f71bbf7436bb5807f83060ab697b53a93b66f0e3a7ca6e791a45da8d468fc1616b991fc50292dd911ff6a66093e73b9216f8f28fe1434388e4d86c873537c
DIST kinfocenter-5.27.0.tar.xz 1015352 BLAKE2B dee8279cbd20fa4b97cd6874fa86aacf04f4a82cbb239e7c5b3527554d90297c8096055622225f02e5bcddee4ced717a4ccc867cb4612ba272118831c0f70eeb SHA512 a0f4f6880d9813dbf1f55627e51dea0b7e228f78c7b135bc6ea91e4d06cc31ee03edbc5ad8e63f161bfd2b40e5166e3e169630af59b035d6287b28f62d0af51d
+DIST kinfocenter-5.27.1.tar.xz 1015384 BLAKE2B 25b8a60ccb65a9471d7780b458fb840bedd4187a7aa09ec9b22bb8d9254bbdd21ca303557c7b29c801226a0f4152333d678cd13b416ae42f124e3984152dc4af SHA512 31291ea89f35a1583d33ab38d175367e24b7834ebb49aa08de49bdd32c95b428d9af028dc0eda8689997c87d3f843704922a54769a2fd1ee44559296594d3690
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.27.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.27.1.ebuild
new file mode 100644
index 000000000000..9771a9a251ac
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.27.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qdbus:*
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}