summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-21 22:57:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-21 23:27:55 +0200
commit61eb413fb55a22930e76ac7dd9b6b6557483742d (patch)
tree4df12abfbd2faf625d5887627f18e4fef5b45704 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.25.1 version bump (diff)
downloadgentoo-61eb413fb55a22930e76ac7dd9b6b6557483742d.tar.gz
gentoo-61eb413fb55a22930e76ac7dd9b6b6557483742d.tar.bz2
gentoo-61eb413fb55a22930e76ac7dd9b6b6557483742d.zip
kde-plasma/kinfocenter: 5.25.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.25.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 5eb2367800dd..7e25913d335d 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.24.5.tar.xz 719404 BLAKE2B 49ac1db6f1e98fdd2575f43891ebb27448f211d61d811496f4a54170806ed2df80211f7248bec093e45855625b3ba6f768ec66b070b196de9452205b632fbbcf SHA512 598d7993808ac6f32ae89c2a50624caf81c4d7a355ae155469d79fda923d3bcd4256077863186a42d594ddd36c06ffb5c3fd02987cf638b2bc88dffdb9b47883
DIST kinfocenter-5.25.0.tar.xz 731260 BLAKE2B 81aefdf8d89738c1d4c4eaba59ffe581651e7abb3fce62a850c10655da9c09333937c43222ad4afefd1f870031ef66eb21783c90295016f8398d85967cce3520 SHA512 bbde3af28343f9915791cdd7122a8c4e3e759edbcdf34bfcfb1054319020f9f6b5a8595b58360675bdcedb5fbdeda8b9dd16e3c537002bc28d95175aac53a099
+DIST kinfocenter-5.25.1.tar.xz 730988 BLAKE2B ad9105b652df332f2d780f12c992497b1d313f2d60c98ae00a78cfa8a5eb1dc2315ed7a0611dcb861b401641c12fcee6bce93b65e8ab685f49e0762361712bd2 SHA512 d0fe14f7324417c64518e30e94d22dd3eff678e828ba06e12cbecddcf18b5317fd4e24285d16f405c7116b7d0729ae089a48885bf94d4a208054feafa306b75c
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.25.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.25.1.ebuild
new file mode 100644
index 000000000000..022c706b75c9
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.25.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.94.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.4
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}