summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/kmenuedit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/kmenuedit')
-rw-r--r--kde-plasma/kmenuedit/Manifest1
-rw-r--r--kde-plasma/kmenuedit/kmenuedit-5.3.2.ebuild45
-rw-r--r--kde-plasma/kmenuedit/metadata.xml8
3 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/kmenuedit/Manifest b/kde-plasma/kmenuedit/Manifest
new file mode 100644
index 000000000000..3c8e29b1e294
--- /dev/null
+++ b/kde-plasma/kmenuedit/Manifest
@@ -0,0 +1 @@
+DIST kmenuedit-5.3.2.tar.xz 441832 SHA256 b199a0c8214bac0b6833ab2c0018daaecf49a1881fe5b34c540940940c94da8e SHA512 b050a938ae1ae72eb62192f41a905120b94fc2b3f42345c6934849f5b2dd2faacdd6424b0b9877812350d036ff433727ecce1109c536b7bbe3d439d51c610221 WHIRLPOOL 0cfe1f07cecd359e07c5e9a655e576f9074a6716eab56912ecd028bf1e65ac58ca51f6ef485cb8dcb57081bfb450c63ad9f9dfa6c7b53a278040c6946fad5fca
diff --git a/kde-plasma/kmenuedit/kmenuedit-5.3.2.ebuild b/kde-plasma/kmenuedit/kmenuedit-5.3.2.ebuild
new file mode 100644
index 000000000000..34792b5bff2d
--- /dev/null
+++ b/kde-plasma/kmenuedit/kmenuedit-5.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="KDE menu editor"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kmenuedit"
+KEYWORDS="~amd64"
+IUSE="+hotkeys"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ hotkeys? ( $(add_plasma_dep khotkeys) )
+"
+RDEPEND="${DEPEND}
+ !kde-base/kmenuedit
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package hotkeys KHotKeysDBusInterface)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-plasma/kmenuedit/metadata.xml b/kde-plasma/kmenuedit/metadata.xml
new file mode 100644
index 000000000000..b5928c371d7a
--- /dev/null
+++ b/kde-plasma/kmenuedit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="hotkeys">Enable support for hotkey editing</flag>
+ </use>
+</pkgmetadata>