summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 22:09:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 22:18:22 +0100
commitb1d95d96b933e34d9ad98e865153ba1f92361511 (patch)
treed975383816e2225948e7a3a46c6d85d063af876d /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.21.1 version bump (diff)
downloadgentoo-b1d95d96b933e34d9ad98e865153ba1f92361511.tar.gz
gentoo-b1d95d96b933e34d9ad98e865153ba1f92361511.tar.bz2
gentoo-b1d95d96b933e34d9ad98e865153ba1f92361511.zip
kde-plasma/ksshaskpass: 5.21.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.21.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 543496627ed6..707ef6630f7d 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.20.5.tar.xz 23516 BLAKE2B 328adfbf6ca7adcc9d9fbdb22d86e0e44b4056b4d7b3c3af13ebede5002ed587aa2102c6a90c27691f102f2c15ce08d2876e1dea6cd0c20833a21800b0b3fd21 SHA512 2dbe7b59b3469ae4ab20b896d11f354c6e335e5178a8647f1e71a311389b29c16cbba7fc925053ade3076063af9fd0497af3b8e060e554e68ba40b8fef47de55
DIST ksshaskpass-5.21.0.tar.xz 24036 BLAKE2B 1649b92dfbd517359645136116456b62885759a77cfc08ac01dd6848f3c523d10a1126315c4360a20bd5749b332d01d4f0528174de483fb17cf6c286c5adaebb SHA512 1056df56db91394ff1a8b56000147beb5cd6078835e0dd0903258d567ce15cd668a01509bf90eb2bf6a66b422bbd2082d4a21c2689352f6f160eeab432f62a5b
+DIST ksshaskpass-5.21.1.tar.xz 24064 BLAKE2B 9e0d0c67eef38c944182ced773b01798af69cca1bafcabcdf0ed8b1c8877171d94531f41ea37f4448d1fe01497c55b9e1e1b6906fced9f61ce663ae3e9c9f7b2 SHA512 aed29f180a560122557002f4107fb22bb8e385a6514ce3e056bbddd85520a7d536d4390b666b5725473ea433c5af65982ac7b89b9921b2429de2fccf898c8fcc
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.21.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.21.1.ebuild
new file mode 100644
index 000000000000..264ce2581b93
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.21.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.78.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}