summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-27 22:44:56 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-27 22:45:24 +0200
commitad9b3995a238dd866e0e405907887ad30add40fa (patch)
tree26c0d64a118d352973220848dcd035958116e206 /kde-plasma/kwallet-pam
parentdev-python/cliff-tablib: Support python3.6 (diff)
downloadgentoo-ad9b3995a238dd866e0e405907887ad30add40fa.tar.gz
gentoo-ad9b3995a238dd866e0e405907887ad30add40fa.tar.bz2
gentoo-ad9b3995a238dd866e0e405907887ad30add40fa.zip
kde-plasma: Version bump KDE Plasma 5.12.6
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.12.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 29c2dacfbd0e..ba20367e2506 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.12.5.tar.xz 18584 BLAKE2B aa5cef35532288e4ff01c483ec2971c4729bd6d3a039981f5873348a39a6b618d43e635cd24a1d8e10f50ff0e9df005ee7aa31c2f1a9695e93733d6157577128 SHA512 b62518019ec2c8c5251198f9498c66b4768cf91851dd112dea1ac5d2e6ef1a500905afcdc2ff88cf4d26efaed7af508af022b811ba42424a71b4199ae03b0eec
+DIST kwallet-pam-5.12.6.tar.xz 18596 BLAKE2B 5ec1638bd71518eaf91becb548392e4df78ff56922c0574ee8981dcc35a3f8d4c00562bbd5cabe9192a727f127cd66ecd3e5b2c3a1a1c59082d5fc1f8ad95d7b SHA512 d0fb215b40ed3bc7c5b6236a4c9e34cf1ecca2ceadfe411c51747d72c503712258ab70e67e2b0025ec0f4488caa6c21bcd4573e2eab98be5b9aae70ae3b5ce48
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.12.6.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.12.6.ebuild
new file mode 100644
index 000000000000..8c9a7437fc09
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.12.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}