summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-10 23:18:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-11 00:04:01 +0100
commit99ca1a1da10e41cfb0ced293de453a38a223c43b (patch)
tree1137122a384eb18788b06e3b486f20dfb715ffc2 /kde-plasma/kwayland-integration
parentkde-plasma/kwayland: 5.92.0 version bump (diff)
downloadgentoo-99ca1a1da10e41cfb0ced293de453a38a223c43b.tar.gz
gentoo-99ca1a1da10e41cfb0ced293de453a38a223c43b.tar.bz2
gentoo-99ca1a1da10e41cfb0ced293de453a38a223c43b.zip
kde-plasma/kwayland-integration: 5.92.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.92.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 010345db3198..9a7d203fe323 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.27.10.tar.xz 25776 BLAKE2B dbd1b2cedf1128f59318e41036bde63c8062538804a6b26418bce2210860a0b0f1dcbf217f9b823924ec8865b2bc3d6ceae7a06339d8ea1a508d67763e697027 SHA512 c66b08ba2af7675add7d603e0b8bdd20578abfc71af15574c389c8bec9856f309fe856c236f9fc8832e38c0125f5d55a3cc3d649b9d49733ee93d656b9c293fe
DIST kwayland-integration-5.91.0.tar.xz 26352 BLAKE2B 0a3dd88dfa1c0804e128b20c9b6ed8d28de534a19cac4c22584050e8903cc83a9629431e10759125112a486215980fe1bac10d38537fc0e79bd9ed1277a1e250 SHA512 04b68fc1572bf6218bb8dd2e09fbed2c7dfb7ea91581a5d0503cac40865fb83597d537cf4c12a0cbb56d134c585148c4d3f1bb6ff2e52b26231c8be4eddc3baa
+DIST kwayland-integration-5.92.0.tar.xz 26448 BLAKE2B 44b251ede14c4b5974e546d6ff8de61ec1c91a29cb220c8be8fcf4fb024e96cd28c19d5b4e01d7c63fba48aa63c5e2842b97e90f6f32eaebc43722c8f5a104c6 SHA512 106887e68c5203645eef38a4915a344714a931966110202d2f350ef49fc262683cc85062c119a5369b2b6aa903d6648e33d3c23b422d08d104bfc0aacd5b0c71
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.92.0.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.92.0.ebuild
new file mode 100644
index 000000000000..05e2a781adb1
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.92.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.113.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"