summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-11-06 14:04:41 +0100
committerSam James <sam@gentoo.org>2022-01-21 19:06:53 +0000
commitfa21a7c55550423ce58d13fe5ca82cd79d4c3005 (patch)
treec958dadae4091fc5de025674ffd62a87911129a6 /lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
parentlxqt-base/lxqt-openssh-askpass: version bump to 1.0.0 (diff)
downloadgentoo-fa21a7c55550423ce58d13fe5ca82cd79d4c3005.tar.gz
gentoo-fa21a7c55550423ce58d13fe5ca82cd79d4c3005.tar.bz2
gentoo-fa21a7c55550423ce58d13fe5ca82cd79d4c3005.zip
lxqt-base/lxqt-admin: version bump to 1.0.0
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild')
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
new file mode 100644
index 000000000000..f98a17eedd2d
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.10.0"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ kde-frameworks/kwindowsystem:5
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"