summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-11-09 22:40:26 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-11-10 14:55:34 +0200
commit8ccd7e46d167bbcb8e8347ae9ec0deba9db2c1c3 (patch)
treeed4fb0f56b6b60a28b7f52cd0c0977ac2b10018c /lxqt-base/lxqt-sudo/lxqt-sudo-1.2.0.ebuild
parentlxqt-base/lxqt-session: add version 1.2.0 (diff)
downloadgentoo-8ccd7e46d167bbcb8e8347ae9ec0deba9db2c1c3.tar.gz
gentoo-8ccd7e46d167bbcb8e8347ae9ec0deba9db2c1c3.tar.bz2
gentoo-8ccd7e46d167bbcb8e8347ae9ec0deba9db2c1c3.zip
lxqt-base/lxqt-sudo: add version 1.2.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-sudo/lxqt-sudo-1.2.0.ebuild')
-rw-r--r--lxqt-base/lxqt-sudo/lxqt-sudo-1.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-sudo/lxqt-sudo-1.2.0.ebuild b/lxqt-base/lxqt-sudo/lxqt-sudo-1.2.0.ebuild
new file mode 100644
index 000000000000..6a99c7f16e21
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/lxqt-sudo-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt GUI frontend for sudo"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.12.0"
+DEPEND="
+ app-admin/sudo
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ ~lxqt-base/liblxqt-${PV}:=
+"
+RDEPEND="${DEPEND}"