summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-11-24 00:09:43 +0200
committerJimi Huotari <chiitoo@gentoo.org>2024-11-24 00:10:29 +0200
commit734daf34d87bca877a68584cf9576b8c2ab85868 (patch)
tree171263a50c2ee80908752a6ad65d5db50ffb27c0 /lxqt-base
parentdev-python/frozenlist: Stabilize 1.5.0 hppa, #943084 (diff)
downloadgentoo-734daf34d87bca877a68584cf9576b8c2ab85868.tar.gz
gentoo-734daf34d87bca877a68584cf9576b8c2ab85868.tar.bz2
gentoo-734daf34d87bca877a68584cf9576b8c2ab85868.zip
lxqt-base/lxqt-qtplugin: add version specifier on 'libdbusmenu-lxqt'
Closes: https://bugs.gentoo.org/show_bug.cgi?id=944732 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0-r1.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..b486c5aa8ae7
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.1.0
+"
+DEPEND="
+ >=dev-libs/libdbusmenu-lxqt-0.2.0
+ >=dev-libs/libqtxdg-4.1.0
+ >=dev-qt/qtbase-6.6:6=[dbus,gui,widgets]
+ =x11-libs/libfm-qt-${MY_PV}*
+"
+RDEPEND="${DEPEND}"