summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-31 16:51:57 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-10-31 16:56:28 +0100
commit01e22106072edf393d9d8f07611efc013be3035a (patch)
treeda7084a79dd00da0c95edb0f61927b313014a09f /mail-client
parentwww-client/firefox: force stderr for ewarn in llvm_check_deps() (diff)
downloadgentoo-01e22106072edf393d9d8f07611efc013be3035a.tar.gz
gentoo-01e22106072edf393d9d8f07611efc013be3035a.tar.bz2
gentoo-01e22106072edf393d9d8f07611efc013be3035a.zip
mail-client/thunderbird: force stderr for ewarn in llvm_check_deps()
Closes: https://bugs.gentoo.org/695668 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-68.2.1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/mail-client/thunderbird/thunderbird-68.2.1.ebuild b/mail-client/thunderbird/thunderbird-68.2.1.ebuild
index e96e0a6bf233..7d71069196c9 100644
--- a/mail-client/thunderbird/thunderbird-68.2.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-68.2.1.ebuild
@@ -182,37 +182,36 @@ fi
llvm_check_deps() {
if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
- ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
- if use pgo ; then
- if ! has usersandbox $FEATURES ; then
- eerror "You must enable usersandbox as X server can not run as root!"
- fi
- fi
-
if use clang ; then
if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
- ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
if use pgo ; then
if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
- ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
fi
fi
- # <EAPI 7 workaround, #695668
einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
}
pkg_setup() {
moz_pkgsetup
+ if use pgo ; then
+ if ! has usersandbox $FEATURES ; then
+ die "You must enable usersandbox as X server can not run as root!"
+ fi
+ fi
+
# Avoid PGO profiling problems due to enviroment leakage
# These should *always* be cleaned up anyway
unset DBUS_SESSION_BUS_ADDRESS \