summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:18:27 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:13 +0300
commita867b458692e16ab64675fa56bbfd70dec17a311 (patch)
treeef2bb883afb000c25161973c658f6b80436bd37e /mate-extra/mate-calc/mate-calc-1.28.0.ebuild
parentmate-extra/mate-calc: drop 1.27.0-r1 (diff)
downloadgentoo-a867b458692e16ab64675fa56bbfd70dec17a311.tar.gz
gentoo-a867b458692e16ab64675fa56bbfd70dec17a311.tar.bz2
gentoo-a867b458692e16ab64675fa56bbfd70dec17a311.zip
mate-extra/mate-calc: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-extra/mate-calc/mate-calc-1.28.0.ebuild')
-rw-r--r--mate-extra/mate-calc/mate-calc-1.28.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/mate-extra/mate-calc/mate-calc-1.28.0.ebuild b/mate-extra/mate-calc/mate-calc-1.28.0.ebuild
new file mode 100644
index 000000000000..f61ab3495336
--- /dev/null
+++ b/mate-extra/mate-calc/mate-calc-1.28.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Calculator for MATE"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ dev-libs/libxml2:2
+ dev-libs/mpc:=
+ >=dev-libs/mpfr-4.0.2:=
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"