summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2015-08-10 14:38:01 +0200
committerGuilherme Amadio <amadio@gentoo.org>2015-08-10 14:38:01 +0200
commit279cbb1b6ee11b2d73bb5caeceafbaaf16b0a02b (patch)
tree4b13aa8b978453d4399adfce385d1c953b050678 /media-fonts/monoid/monoid-0.60.ebuild
parentnet-mail/cyrus-imapd: version bump (diff)
downloadgentoo-279cbb1b6ee11b2d73bb5caeceafbaaf16b0a02b.tar.gz
gentoo-279cbb1b6ee11b2d73bb5caeceafbaaf16b0a02b.tar.bz2
gentoo-279cbb1b6ee11b2d73bb5caeceafbaaf16b0a02b.zip
media-fonts/monoid: new ebuild
Thanks for José Romildo Malaquias <jrmalaq@gmail.com> for filing bug 556108 and for providing first ebuild. Package-Manager: portage-2.2.18
Diffstat (limited to 'media-fonts/monoid/monoid-0.60.ebuild')
-rw-r--r--media-fonts/monoid/monoid-0.60.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-fonts/monoid/monoid-0.60.ebuild b/media-fonts/monoid/monoid-0.60.ebuild
new file mode 100644
index 000000000000..659aab66d99e
--- /dev/null
+++ b/media-fonts/monoid/monoid-0.60.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit font multiprocessing
+
+DESCRIPTION="Open source coding font"
+HOMEPAGE="http://larsenwork.com/monoid https://github.com/larsenwork/monoid"
+SRC_URI="https://github.com/larsenwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND="media-gfx/fontforge[python]"
+RDEPEND=""
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}/_release"
+DOCS="Readme.md"
+
+src_compile() {
+ local NJOBS=$(makeopts_jobs)
+ for x in Source/*.sfdir; do
+ Scripts/build.py ${NJOBS} ${NJOBS} $x
+ done
+}