summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/comix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/comix')
-rw-r--r--media-gfx/comix/Manifest1
-rw-r--r--media-gfx/comix/comix-4.0.4-r1.ebuild78
-rw-r--r--media-gfx/comix/files/comix-4.0.4-pillow.patch153
-rw-r--r--media-gfx/comix/metadata.xml13
4 files changed, 245 insertions, 0 deletions
diff --git a/media-gfx/comix/Manifest b/media-gfx/comix/Manifest
new file mode 100644
index 000000000000..2a83e99f30ef
--- /dev/null
+++ b/media-gfx/comix/Manifest
@@ -0,0 +1 @@
+DIST comix-4.0.4.tar.gz 481687 SHA256 9352169de856957a16de76867fbd7dc711648edfbac7ce76191b55e5f6cd546a SHA512 9cbc5b1cc100ee50b48b794ce9a7f08130fc7a79376533f0f55904be0e2e8cfe5f8b1deeff2f76e7038a3f81b0f709ce5eea88a709199e1584b73f5259df5f8e WHIRLPOOL 0016cb64185a6cd8983b7ecec7877f64f29a36dafd4d80b7dddcfdc8ebd1a13453faaad50d068c75bb250fbf421b7f2a9235f5472ec7d35073f62ac2731f1534
diff --git a/media-gfx/comix/comix-4.0.4-r1.ebuild b/media-gfx/comix/comix-4.0.4-r1.ebuild
new file mode 100644
index 000000000000..6cc76181ef6d
--- /dev/null
+++ b/media-gfx/comix/comix-4.0.4-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PLOCALES="ca cs es fr hr hu id ja ko pl pt_BR ru sv zh_CN zh_TW"
+
+inherit eutils fdo-mime gnome2-utils l10n python-single-r1
+
+DESCRIPTION="A GTK image viewer specifically designed to handle comic books"
+HOMEPAGE="http://comix.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="rar"
+
+DEPEND="${PYTHON_DEPS}
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ rar? ( || ( app-arch/unrar app-arch/rar ) )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ l10n_find_plocales_changes messages "" "/LC_MESSAGES/comix.po"
+
+ epatch "${FILESDIR}/${P}-pillow.patch" #471522, https://sourceforge.net/p/comix/patches/50/
+
+ # do not install .pyc into /usr/share
+ local pythondir="$(python_get_sitedir)/comix"
+ pythondir="${pythondir#${EPREFIX}/usr/}"
+ sed -i -e "s:share/comix/src:${pythondir}:g" install.py || die
+ python_fix_shebang mime/comicthumb src/comix.py
+}
+
+src_install() {
+ dodir /usr
+ "${PYTHON}" install.py install --no-mime --dir "${D}"usr || die
+
+ insinto /usr/share/mime/packages
+ doins mime/comix.xml
+
+ insinto /etc/gconf/schemas
+ doins mime/comicbook.schemas
+
+ dobin mime/comicthumb
+ dodoc ChangeLog README
+
+ remove_locale() {
+ rm -r "${ED}/usr/share/locale/"$1 || die
+ }
+ l10n_for_each_disabled_locale_do remove_locale
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-gfx/comix/files/comix-4.0.4-pillow.patch b/media-gfx/comix/files/comix-4.0.4-pillow.patch
new file mode 100644
index 000000000000..f91bfcd8b821
--- /dev/null
+++ b/media-gfx/comix/files/comix-4.0.4-pillow.patch
@@ -0,0 +1,153 @@
+From 9d31aa97c8bcc7828e6d04ec4375a75a9bf06836 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 16 Jun 2013 13:36:08 -0400
+Subject: [PATCH] Update PIL import statements for compatibility with Pillow
+ (PIL-2)
+
+https://bugs.gentoo.org/show_bug.cgi?id=471522
+---
+ install.py | 2 +-
+ mime/comicthumb | 2 +-
+ src/comix.py | 2 +-
+ src/histogram.py | 6 +++---
+ src/image.py | 8 ++++----
+ src/library.py | 4 ++--
+ src/thumbbar.py | 4 ++--
+ src/thumbnail.py | 2 +-
+ src/thumbremover.py | 2 +-
+ 9 files changed, 16 insertions(+), 16 deletions(-)
+
+diff --git a/install.py b/install.py
+index f8be7cb..d72d8d1 100755
+--- a/install.py
++++ b/install.py
+@@ -240,7 +240,7 @@ def check_dependencies():
+ print ' !!! PyGTK .................... Not found'
+ required_found = False
+ try:
+- import Image
++ from PIL import Image
+ assert Image.VERSION >= '1.1.5'
+ print ' Python Imaging Library ....... OK'
+ except ImportError:
+diff --git a/mime/comicthumb b/mime/comicthumb
+index 1081dac..a3e6a83 100755
+--- a/mime/comicthumb
++++ b/mime/comicthumb
+@@ -22,7 +22,7 @@ import tarfile
+ import subprocess
+
+ try:
+- import Image
++ from PIL import Image
+ except ImportError:
+ print '! Could not import the Image module (PIL).'
+ print __doc__
+diff --git a/src/comix.py b/src/comix.py
+index f3f9e1b..ebc73e9 100755
+--- a/src/comix.py
++++ b/src/comix.py
+@@ -51,7 +51,7 @@ except ImportError:
+ sys.exit(1)
+
+ try:
+- import Image
++ from PIL import Image
+ assert Image.VERSION >= '1.1.5'
+ except AssertionError:
+ print "You don't have the required version of the Python Imaging",
+diff --git a/src/histogram.py b/src/histogram.py
+index e9fc68d..42ac9b8 100644
+--- a/src/histogram.py
++++ b/src/histogram.py
+@@ -1,9 +1,9 @@
+ """histogram.py - Draw histograms (RGB) from pixbufs."""
+
+ import gtk
+-import Image
+-import ImageDraw
+-import ImageOps
++from PIL import Image
++from PIL import ImageDraw
++from PIL import ImageOps
+
+ import image
+
+diff --git a/src/image.py b/src/image.py
+index 0603f0a..db51525 100644
+--- a/src/image.py
++++ b/src/image.py
+@@ -1,10 +1,10 @@
+ """image.py - Various image manipulations."""
+
+ import gtk
+-import Image
+-import ImageEnhance
+-import ImageOps
+-import ImageStat
++from PIL import Image
++from PIL import ImageEnhance
++from PIL import ImageOps
++from PIL import ImageStat
+
+ from preferences import prefs
+
+diff --git a/src/library.py b/src/library.py
+index a4fc29b..e14a197 100644
+--- a/src/library.py
++++ b/src/library.py
+@@ -8,8 +8,8 @@ from xml.sax.saxutils import escape as xmlescape
+ import gtk
+ import gobject
+ import pango
+-import Image
+-import ImageDraw
++from PIL import Image
++from PIL import ImageDraw
+
+ import archive
+ import encoding
+diff --git a/src/thumbbar.py b/src/thumbbar.py
+index ba4b94c..0a4c33f 100644
+--- a/src/thumbbar.py
++++ b/src/thumbbar.py
+@@ -4,8 +4,8 @@ import urllib
+
+ import gtk
+ import gobject
+-import Image
+-import ImageDraw
++from PIL import Image
++from PIL import ImageDraw
+
+ import image
+ from preferences import prefs
+diff --git a/src/thumbnail.py b/src/thumbnail.py
+index 25f333e..b565162 100644
+--- a/src/thumbnail.py
++++ b/src/thumbnail.py
+@@ -15,7 +15,7 @@ import shutil
+ import tempfile
+
+ import gtk
+-import Image
++from PIL import Image
+
+ import archive
+ import constants
+diff --git a/src/thumbremover.py b/src/thumbremover.py
+index fc2fa37..03aa6e6 100644
+--- a/src/thumbremover.py
++++ b/src/thumbremover.py
+@@ -7,7 +7,7 @@ import urllib
+
+ import gtk
+ import pango
+-import Image
++from PIL import Image
+
+ import encoding
+ import labels
+--
+1.8.2.1
+
diff --git a/media-gfx/comix/metadata.xml b/media-gfx/comix/metadata.xml
new file mode 100644
index 000000000000..2d8ef46af84b
--- /dev/null
+++ b/media-gfx/comix/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <use>
+ <flag name="rar">
+ Pulls app-arch/unrar for rar file support
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">comix</remote-id>
+ </upstream>
+</pkgmetadata>