summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2023-01-10 17:41:58 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-01-20 15:50:36 +0200
commit39c17b6645615435e2554c3ae15927906cb951fd (patch)
tree03e15102d98c12910930be667dc3b2f6bbfe9d50 /media-gfx/converseen/converseen-0.9.10.0.ebuild
parentmedia-gfx/tuxpaint: drop 0.9.24-r2, 0.9.28-r1 (diff)
downloadgentoo-39c17b6645615435e2554c3ae15927906cb951fd.tar.gz
gentoo-39c17b6645615435e2554c3ae15927906cb951fd.tar.bz2
gentoo-39c17b6645615435e2554c3ae15927906cb951fd.zip
media-gfx/converseen: add 0.9.10.0
Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/29052 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/converseen/converseen-0.9.10.0.ebuild')
-rw-r--r--media-gfx/converseen/converseen-0.9.10.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/converseen/converseen-0.9.10.0.ebuild b/media-gfx/converseen/converseen-0.9.10.0.ebuild
new file mode 100644
index 000000000000..45e1cbd45d90
--- /dev/null
+++ b/media-gfx/converseen/converseen-0.9.10.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Batch image converter and resizer based on ImageMagick"
+HOMEPAGE="https://converseen.fasterland.net/
+ https://github.com/Faster3ck/Converseen/"
+SRC_URI="https://github.com/Faster3ck/Converseen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# FIXME: graphicsmagick dependency does not work properly, failures when compiling
+# || ( media-gfx/imagemagick[cxx] media-gfx/graphicsmagick[cxx,imagemagick] )
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-gfx/imagemagick:=[cxx]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.9.0-appdata-path.patch"
+ "${FILESDIR}/${PN}-0.9.9.0-no-update.patch"
+)
+
+pkg_postinst() {
+ elog "Please note that due to security policy restrictions"
+ elog "on media-gfx/imagemagick the support for PS, PDF and"
+ elog "XPS files must be explicitly enabled by commenting out"
+ elog "the respective policies in /etc/ImageMagick-7/policy.xml."
+ elog "See https://wiki.gentoo.org/wiki/ImageMagick#Troubleshooting"
+ elog "for more information."
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}