summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-23 19:16:58 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-23 19:16:58 -0700
commit4dff4edd24bb0d3233bb0b077c2b4e00f037b801 (patch)
tree7e0b6f059589c5a1d6a1c548f68b551814109320 /media-gfx/eog-plugins
parentgnome-extra/gnome-system-monitor: Version bump to 42.0 (diff)
downloadgentoo-4dff4edd24bb0d3233bb0b077c2b4e00f037b801.tar.gz
gentoo-4dff4edd24bb0d3233bb0b077c2b4e00f037b801.tar.bz2
gentoo-4dff4edd24bb0d3233bb0b077c2b4e00f037b801.zip
media-gfx/eog-plugins: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-42.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 2fb00b12bf1d..462556e24dbb 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-3.26.8.tar.xz 479356 BLAKE2B ab781311473e045ffbb88e741427ac59f129fa53e6c551231d7b6edae81d21483dd1f1e7874561dfa29c9e9b2ba01fbdb174302bf8363478b785ec2ce38c53ec SHA512 a58aa849b09761dd0c7f7d31098560969872b03788f3f3ee81445dfb9be653b29e0e6646abc4e0164e4146abf7a9d2e6aadf56071f71c119493dcf1fd706a069
+DIST eog-plugins-42.0.tar.xz 132008 BLAKE2B 0dbe9ddcdf8f9a7f4da46caffe091a5d6e09327e1277b41474ecf8a3ec63ee7217fdc0cbafd1c47007f83b8ae30f30d91031c76f31473df79cda01aee23314ea SHA512 297b31fefa28f4eda73734ddcdb7702b9c9fa3493b4c13d3bf013e24ddb9015299bcd8f2af6a1976c4bf8c694fea0cc9699e82755d5e0689e71738a6d2fb2fe4
diff --git a/media-gfx/eog-plugins/eog-plugins-42.0.ebuild b/media-gfx/eog-plugins/eog-plugins-42.0.ebuild
new file mode 100644
index 000000000000..ae3bb0bb211a
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-42.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:=
+ >=media-gfx/eog-41.0
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}