summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/freepv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/freepv')
-rw-r--r--media-gfx/freepv/Manifest1
-rw-r--r--media-gfx/freepv/files/freepv-0.3.0-gcc44.patch60
-rw-r--r--media-gfx/freepv/files/freepv-0.3.0-gcc46.patch10
-rw-r--r--media-gfx/freepv/files/freepv-0.3.0-libpng14.patch20
-rw-r--r--media-gfx/freepv/files/freepv-0.3.0-noplugin.patch30
-rw-r--r--media-gfx/freepv/files/freepv-0.3.0-stringh.patch10
-rw-r--r--media-gfx/freepv/freepv-0.3.0-r4.ebuild40
-rw-r--r--media-gfx/freepv/metadata.xml12
8 files changed, 183 insertions, 0 deletions
diff --git a/media-gfx/freepv/Manifest b/media-gfx/freepv/Manifest
new file mode 100644
index 000000000000..59ad54d81374
--- /dev/null
+++ b/media-gfx/freepv/Manifest
@@ -0,0 +1 @@
+DIST freepv-0.3.0.tar.gz 175545 SHA256 a66c58616cbe814b2e23c6fe109c3de906dad83a8faa32ea219c182bf15229f0 SHA512 0b207dc25c51b19fd76637743adb8e395c6098d03611612086d66d3f1aa6e4d0c5700aa0e23210082d6aa7495f19d1c3d8f0f93ad11a5236df86d709d5f71a7d WHIRLPOOL 993378bb9ef25e1a1064f9402c4608d0a54588f035f23fc67024b857705ff978a403f86e5140e9ed88b83a6d9ae7a74aa86bf9c0239eb07348904d1eeb9ef749
diff --git a/media-gfx/freepv/files/freepv-0.3.0-gcc44.patch b/media-gfx/freepv/files/freepv-0.3.0-gcc44.patch
new file mode 100644
index 000000000000..af5b1a0d196e
--- /dev/null
+++ b/media-gfx/freepv/files/freepv-0.3.0-gcc44.patch
@@ -0,0 +1,60 @@
+diff -Naur freepv-0.3.0.orig/src/libfreepv/OpenGLRenderer.cpp freepv-0.3.0/src/libfreepv/OpenGLRenderer.cpp
+--- freepv-0.3.0.orig/src/libfreepv/OpenGLRenderer.cpp 2010-03-11 16:15:04.000000000 +0100
++++ freepv-0.3.0/src/libfreepv/OpenGLRenderer.cpp 2010-03-11 16:25:15.000000000 +0100
+@@ -26,7 +26,8 @@
+ #include <config.h>
+
+ #include <vector>
+-#include <math.h>
++#include <cmath>
++#include <cstdio>
+
+ #include "OpenGLRenderer.h"
+ #include "Scene.h"
+diff -Naur freepv-0.3.0.orig/src/libfreepv/QTVRDecoder.cpp freepv-0.3.0/src/libfreepv/QTVRDecoder.cpp
+--- freepv-0.3.0.orig/src/libfreepv/QTVRDecoder.cpp 2010-03-11 16:15:04.000000000 +0100
++++ freepv-0.3.0/src/libfreepv/QTVRDecoder.cpp 2010-03-11 16:25:15.000000000 +0100
+@@ -42,6 +42,7 @@
+ #include <errno.h>
+ #include <vector>
+ #include <cstring>
++#include <cstdio>
+
+ #include <zlib.h>
+
+diff -Naur freepv-0.3.0.orig/src/libfreepv/SPiVparser.cpp freepv-0.3.0/src/libfreepv/SPiVparser.cpp
+--- freepv-0.3.0.orig/src/libfreepv/SPiVparser.cpp 2010-03-11 16:15:04.000000000 +0100
++++ freepv-0.3.0/src/libfreepv/SPiVparser.cpp 2010-03-11 16:18:53.000000000 +0100
+@@ -488,8 +488,8 @@
+ //This method remplace the nodes that has src attributes
+ void SPiVparser::parseNodeURL(const char* _url)
+ {
+- char * aux_url=NULL;
+- char * url=(char*) _url;
++ const char * aux_url=NULL;
++ const char * url=(char*) _url;
+ if(aux_url = strrchr (_url,'/'))
+ {
+ url=aux_url;
+diff -Naur freepv-0.3.0.orig/src/libfreepv/Utils/signatures.cpp freepv-0.3.0/src/libfreepv/Utils/signatures.cpp
+--- freepv-0.3.0.orig/src/libfreepv/Utils/signatures.cpp 2010-03-11 16:15:04.000000000 +0100
++++ freepv-0.3.0/src/libfreepv/Utils/signatures.cpp 2010-03-11 16:25:15.000000000 +0100
+@@ -24,6 +24,7 @@
+
+ #include "signatures.h"
+ #include <iostream>
++#include <cstdio>
+
+ namespace FPV{
+ namespace Utils{
+diff -Naur freepv-0.3.0.orig/src/libfreepv/utils.cpp freepv-0.3.0/src/libfreepv/utils.cpp
+--- freepv-0.3.0.orig/src/libfreepv/utils.cpp 2010-03-11 16:15:04.000000000 +0100
++++ freepv-0.3.0/src/libfreepv/utils.cpp 2010-03-11 16:25:15.000000000 +0100
+@@ -23,6 +23,7 @@
+ */
+
+ #include <algorithm>
++#include <cstdio>
+
+ #include "utils.h"
+
diff --git a/media-gfx/freepv/files/freepv-0.3.0-gcc46.patch b/media-gfx/freepv/files/freepv-0.3.0-gcc46.patch
new file mode 100644
index 000000000000..985d1443e7ce
--- /dev/null
+++ b/media-gfx/freepv/files/freepv-0.3.0-gcc46.patch
@@ -0,0 +1,10 @@
+--- src/libfreepv/Action.h.orig 2011-06-16 17:37:55.705868856 +0200
++++ src/libfreepv/Action.h 2011-06-16 17:38:19.792311535 +0200
+@@ -24,6 +24,7 @@
+
+ #ifndef FPV_ACTION_H
+ #define FPV_ACTION_H
++#include <cstddef>
+ #include "Behavior.h"
+
+ namespace FPV
diff --git a/media-gfx/freepv/files/freepv-0.3.0-libpng14.patch b/media-gfx/freepv/files/freepv-0.3.0-libpng14.patch
new file mode 100644
index 000000000000..e3b614f57490
--- /dev/null
+++ b/media-gfx/freepv/files/freepv-0.3.0-libpng14.patch
@@ -0,0 +1,20 @@
+--- src/libfreepv/pngReader.cpp
++++ src/libfreepv/pngReader.cpp
+@@ -135,7 +135,7 @@
+ //Transfor grayscale images with less
+ //than 8 bits to 8 bits
+ if(color_t == PNG_COLOR_TYPE_GRAY && depth<8)
+- png_set_gray_1_2_4_to_8(p_png_struct);
++ png_set_expand_gray_1_2_4_to_8(p_png_struct);
+
+ //Add a full alpha channel if there is
+ //transparency information in the tRNS chunk
+@@ -283,7 +283,7 @@
+ //Transfor grayscale images with less
+ //than 8 bits to 8 bits.
+ if(color_t == PNG_COLOR_TYPE_GRAY && depth<8)
+- png_set_gray_1_2_4_to_8(p_png_struct);
++ png_set_expand_gray_1_2_4_to_8(p_png_struct);
+
+ //Add a full alpha channel if there is
+ //transparency information in the tRNS chunk
diff --git a/media-gfx/freepv/files/freepv-0.3.0-noplugin.patch b/media-gfx/freepv/files/freepv-0.3.0-noplugin.patch
new file mode 100644
index 000000000000..4ea51d50b0cc
--- /dev/null
+++ b/media-gfx/freepv/files/freepv-0.3.0-noplugin.patch
@@ -0,0 +1,30 @@
+diff -Naur freepv-0.3.0.orig//CMakeLists.txt freepv-0.3.0/CMakeLists.txt
+--- freepv-0.3.0.orig//CMakeLists.txt 2010-03-11 16:05:09.000000000 +0100
++++ freepv-0.3.0/CMakeLists.txt 2010-03-11 16:05:18.000000000 +0100
+@@ -89,7 +89,6 @@
+ find_package(FREEGLUT REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(X11 REQUIRED)
+-find_package(GECKO REQUIRED)
+ find_package(LibXml2 REQUIRED)
+ find_package(PNG REQUIRED)
+ find_package(XF86VM REQUIRED)
+@@ -107,7 +106,6 @@
+ ${OPENGL_INCLUDE_DIR}
+ ${FREEGLUT_INCLUDE_DIR}
+ ${X11_INCLUDE_DIR}
+- ${GECKO_INCLUDE_DIR}
+ ${LIBXML2_INCLUDE_DIR}
+ ${PNG_INCLUDE_DIR}
+ ${XF86VM_INCLUDE_DIR})
+diff -Naur freepv-0.3.0.orig//src/CMakeLists.txt freepv-0.3.0/src/CMakeLists.txt
+--- freepv-0.3.0.orig//src/CMakeLists.txt 2010-03-11 16:05:09.000000000 +0100
++++ freepv-0.3.0/src/CMakeLists.txt 2010-03-11 16:05:28.000000000 +0100
+@@ -5,7 +5,6 @@
+ add_subdirectory (freepv-glut)
+ add_subdirectory (utils)
+ if(UNIX)
+- add_subdirectory (freepv-mozilla)
+ add_subdirectory (freepv-glx)
+ endif(UNIX)
+
diff --git a/media-gfx/freepv/files/freepv-0.3.0-stringh.patch b/media-gfx/freepv/files/freepv-0.3.0-stringh.patch
new file mode 100644
index 000000000000..083585e5750c
--- /dev/null
+++ b/media-gfx/freepv/files/freepv-0.3.0-stringh.patch
@@ -0,0 +1,10 @@
+--- src/libfreepv/Image.cpp.ORIG 2009-05-02 01:12:31.000000000 +0200
++++ src/libfreepv/Image.cpp 2013-04-11 09:37:07.436358208 +0200
+@@ -23,6 +23,7 @@
+ */
+
+ #include <assert.h>
++#include <string.h>
+
+ #include "Image.h"
+ #include "JpegReader.h"
diff --git a/media-gfx/freepv/freepv-0.3.0-r4.ebuild b/media-gfx/freepv/freepv-0.3.0-r4.ebuild
new file mode 100644
index 000000000000..c428f156dc75
--- /dev/null
+++ b/media-gfx/freepv/freepv-0.3.0-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils
+
+DESCRIPTION="Panorama viewer (Quicktime, PangeaVR, GLPanoView formats)"
+HOMEPAGE="http://freepv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freepv/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ media-libs/libpng:0=
+ media-libs/freeglut
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-noplugin.patch \
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-stringh.patch
+
+ sed -i \
+ -e 's:jpeg_mem_src:freepv_jpeg_mem_src:g' \
+ src/libfreepv/JpegReader.cpp || die 'jpeg sed failed'
+
+ sed -i -e 's:^INSTALL(.*)::' \
+ src/libfreepv/CMakeLists.txt || die 'static lib install sed failed'
+}
diff --git a/media-gfx/freepv/metadata.xml b/media-gfx/freepv/metadata.xml
new file mode 100644
index 000000000000..ae44a85f0673
--- /dev/null
+++ b/media-gfx/freepv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>OpenGL accelerated panorama viewer and browser plugin (supports Quicktime, PangeaVR and GLPanoView panoramas)</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">freepv</remote-id>
+ </upstream>
+</pkgmetadata>