summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch')
-rw-r--r--media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch b/media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch
new file mode 100644
index 000000000000..882062cb7e10
--- /dev/null
+++ b/media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch
@@ -0,0 +1,54 @@
+--- a/src/java/Makefile.sources
++++ b/src/java/Makefile.sources
+@@ -1,4 +1,4 @@
+-dist_noinst_JAVA = \
++noinst_JAVA = \
+ org/web3d/x3d/sai/Browser.java \
+ org/web3d/x3d/sai/BrowserEvent.java \
+ org/web3d/x3d/sai/BrowserFactoryImpl.java \
+@@ -309,6 +309,7 @@ noinst_JAVA = \
+ vrml/InvalidFieldException.java \
+ vrml/InvalidRouteException.java \
+ vrml/InvalidVRMLSyntaxException.java \
++ vrml/InvalidX3DSyntaxException.java \
+ vrml/MField.java \
+ vrml/field/ConstMFColor.java \
+ vrml/field/ConstMFFloat.java \
+--- /dev/null
++++ b/src/java/vrml/InvalidX3DSyntaxException.java
+@@ -0,0 +1,6 @@
++package vrml;
++
++public class InvalidX3DSyntaxException extends Exception {
++ public InvalidX3DSyntaxException() { super(); }
++ public InvalidX3DSyntaxException(String s) { super(s); }
++}
+--- a/src/java/Makefile.am 2014-03-10 10:37:09.000000000 -0400
++++ b/src/java/Makefile.am 2014-03-12 12:29:42.000000000 -0400
+@@ -1,5 +1,10 @@
+ # Java Classes for EAI/SAI/etc.
+
++# NOTE - automake-1.11.6 changed how class*.stamp is generated, now need
++# to use noinst_JAVA and EXTRA_DIST instead of dist_noinst_JAVA to
++# keep behaviour consistent and compatible with both automake-1.11.6 and
++# older automake
++
+ # Get global variables for Makefile defined by toplevel Makefile.globals
+ include $(top_srcdir)/Makefile.globals
+
+@@ -9,11 +14,12 @@
+ jarfile = vrml.jar
+ jardir = $(JAVA_DIR)
+
+-$(jarfile): $(dist_noinst_JAVA) classdist_noinst.stamp
+- $(JAR) cmf $(JAVAROOT)/manifest.extras $@ -C $(JAVAROOT) $$(echo $(dist_noinst_JAVA:.java=.class))
++$(jarfile): $(noinst_JAVA) manifest.extras classnoinst.stamp
++ $(JAR) cmf $(JAVAROOT)/manifest.extras $@ -C $(JAVAROOT) $$(echo $(noinst_JAVA:.java=.class))
+
+ jar_DATA = $(jarfile)
+
+-CLEANFILES = $(jarfile) $$(echo $(dist_noinst_JAVA:.java=.class))
++CLEANFILES = $(jarfile) $$(echo $(noinst_JAVA:.java=.class))
++EXTRA_DIST = $(noinst_JAVA) java.policy manifest.extras
+
+ include Makefile.sources