summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-13 01:27:50 +0000
committerSam James <sam@gentoo.org>2021-12-13 01:27:50 +0000
commitd51f6857b8652595ecf27c491040cb64d7112499 (patch)
treea341de54316ec0a15064247028ed438fe657a1de /media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
parentmail-client/thunderbird: revbump to propagate libpng changes (diff)
downloadgentoo-d51f6857b8652595ecf27c491040cb64d7112499.tar.gz
gentoo-d51f6857b8652595ecf27c491040cb64d7112499.tar.bz2
gentoo-d51f6857b8652595ecf27c491040cb64d7112499.zip
media-gfx/graphicsmagick: add 1.3.37
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/graphicsmagick/graphicsmagick-9999.ebuild')
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
index 900a55abda11..903411326261 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
@@ -8,8 +8,6 @@ inherit autotools toolchain-funcs
MY_P=${P/graphicsm/GraphicsM}
DESCRIPTION="Collection of tools and libraries for many image formats"
HOMEPAGE="http://www.graphicsmagick.org/ http://hg.code.sf.net/p/graphicsmagick/code/"
-LICENSE="MIT"
-SLOT="0/${PV%.*}"
if [[ ${PV} == "9999" ]] ; then
inherit mercurial
@@ -17,15 +15,18 @@ if [[ ${PV} == "9999" ]] ; then
else
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
S="${WORKDIR}/${MY_P}"
+
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
-IUSE="bzip2 +cxx debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma
- openmp perl png postscript q16 q32 static-libs svg threads tiff truetype
- webp wmf X zlib"
+LICENSE="MIT"
+SLOT="0/${PV%.*}"
+
+IUSE="bzip2 +cxx debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma"
+IUSE+=" openmp perl png postscript q16 q32 static-libs svg threads tiff truetype"
+IUSE+=" webp wmf X zlib"
-RDEPEND="
- dev-libs/libltdl:0
+RDEPEND="dev-libs/libltdl:0
bzip2? ( app-arch/bzip2 )
fpx? ( media-libs/libfpx )
imagemagick? ( !media-gfx/imagemagick )
@@ -58,6 +59,7 @@ PATCHES=(
src_prepare() {
default
+
eautoreconf
}
@@ -106,16 +108,19 @@ src_configure() {
$(use_with zlib)
$(use_with X x)
)
+
econf "${myeconfargs[@]}"
}
src_compile() {
default
+
use perl && emake perl-build
}
src_test() {
unset DISPLAY # some perl tests fail when DISPLAY is set
+
default
}