summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Eduardo <carana2099@gmail.com>2022-02-16 16:54:48 -0300
committerSam James <sam@gentoo.org>2022-02-18 02:59:43 +0000
commitbce190b6088d92b98d45b93f1b900dd5b8d898b9 (patch)
tree66d1827493610afe616404f3fa11bc3a5fd7334d /media-gfx/jp2a/jp2a-1.1.1.ebuild
parentapp-containers/crun: drop 0.19.1-r1 and patch (diff)
downloadgentoo-bce190b6088d92b98d45b93f1b900dd5b8d898b9.tar.gz
gentoo-bce190b6088d92b98d45b93f1b900dd5b8d898b9.tar.bz2
gentoo-bce190b6088d92b98d45b93f1b900dd5b8d898b9.zip
media-gfx/jp2a: add 1.1.1
Closes: https://bugs.gentoo.org/716744 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Carlos Eduardo <carana2099@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24218 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/jp2a/jp2a-1.1.1.ebuild')
-rw-r--r--media-gfx/jp2a/jp2a-1.1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/jp2a/jp2a-1.1.1.ebuild b/media-gfx/jp2a/jp2a-1.1.1.ebuild
new file mode 100644
index 000000000000..3e88e9c7644d
--- /dev/null
+++ b/media-gfx/jp2a/jp2a-1.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="JPEG image to ASCII art converter"
+HOMEPAGE="https://github.com/Talinx/jp2a/"
+SRC_URI="https://github.com/Talinx/jp2a/releases/download/v${PV}/jp2a-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="curl"
+
+RDEPEND="sys-libs/ncurses
+ virtual/jpeg
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf "$(use_enable curl)"
+}