summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-09-22 12:42:15 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-12-25 10:07:24 +0200
commit91a66474b005dae230f22c3c223ad550b338083c (patch)
treea016ea4a4efc91c54f228ac916999e7f3023fab8 /media-gfx/xloadimage
parentpackage.mask: Last rite x11-libs/libtinynotify-systemwide & rdep (diff)
downloadgentoo-91a66474b005dae230f22c3c223ad550b338083c.tar.gz
gentoo-91a66474b005dae230f22c3c223ad550b338083c.tar.bz2
gentoo-91a66474b005dae230f22c3c223ad550b338083c.zip
media-gfx/xloadimage: fix incomp. func. pointer
Closes: https://bugs.gentoo.org/896232 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/32988 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'media-gfx/xloadimage')
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-fix-incomp-function-pointer-types.patch17
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r16.ebuild93
2 files changed, 110 insertions, 0 deletions
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-fix-incomp-function-pointer-types.patch b/media-gfx/xloadimage/files/xloadimage-4.1-fix-incomp-function-pointer-types.patch
new file mode 100644
index 000000000000..0ddd2da0f65f
--- /dev/null
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-fix-incomp-function-pointer-types.patch
@@ -0,0 +1,17 @@
+Inpompatible function pointers are an error instead of a warning by default since clang16
+
+Bug: https://bugs.gentoo.org/896232
+
+Pascal Jäger <pascal.jaeger@leimstift.de> (2023-09-22)
+
+--- a/window.c
++++ b/window.c
+@@ -833,7 +833,7 @@ char imageInWindow (Display *disp, int scrn, Image *image, OptionSet *global_opt
+ /* reset alarm to -delay seconds after every event */
+ #ifdef ENABLE_TIMEOUT
+ AlarmWentOff = 0;
+- signal(SIGALRM, delayAlarmHandler);
++ signal(SIGALRM, (__sighandler_t)delayAlarmHandler);
+ alarm(delay);
+ #endif /* ENABLE_TIMEOUT */
+ }
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r16.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r16.ebuild
new file mode 100644
index 000000000000..461bdfe35a16
--- /dev/null
+++ b/media-gfx/xloadimage/xloadimage-4.1-r16.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Utility to view many different types of images under X11"
+HOMEPAGE="https://sioseis.ucsd.edu/xloadimage.html https://tracker.debian.org/pkg/xloadimage"
+SRC_URI="
+ ftp://ftp.x.org/R5contrib/${P/-/.}.tar.gz
+ mirror://gentoo/${P}-gentoo-r1.diff.bz2
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-fix-build-for-clang16.patch.xz
+"
+S="${WORKDIR}"/${P/-/.}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="tiff jpeg png"
+
+RDEPEND="x11-libs/libX11
+ tiff? ( media-libs/tiff:= )
+ png? ( media-libs/libpng:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ !media-gfx/xli"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-gentoo-r1.diff
+ "${FILESDIR}"/${P}-zio-shell-meta-char.diff
+ "${FILESDIR}"/${P}-endif.patch
+ # Do not define errno extern, but rather include errno.h
+ # <azarah@gentoo.org> (1 Jan 2003)
+ "${FILESDIR}"/${P}-include-errno_h.patch
+ "${FILESDIR}"/xloadimage-gentoo.patch
+ "${FILESDIR}"/${P}-unaligned-access.patch
+ "${FILESDIR}"/${P}-ldflags_and_exit.patch
+ "${FILESDIR}"/${P}-libpng15.patch
+ "${WORKDIR}"/${P}-fix-build-for-clang16.patch
+ # One of the previous patches screws up a bracket...
+ "${FILESDIR}"/${P}-bracket.patch
+ "${FILESDIR}"/${P}-fix-incomp-function-pointer-types.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "s:OPT_FLAGS=:OPT_FLAGS=$CFLAGS:" Make.conf || die
+ sed -i -e "s:^#include <varargs.h>:#include <stdarg.h>:" rlelib.c || die
+ # qa-sed sees no-op on the next sed on non-gentoo-prefix systems,
+ # but that is alright
+ sed -i -e "/^DEFS = /s:/etc:${EPREFIX}/etc:" Makefile.in || die
+ sed -i \
+ -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
+ png.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Set TIFFHeader to TIFFHeaderCommon wrt #319383
+ has_version '>=media-libs/tiff-4.0.0_pre' && \
+ append-flags -DTIFFHeader=TIFFHeaderCommon
+
+ tc-export CC
+ econf $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff)
+}
+
+src_compile() {
+ emake SYSPATHFILE="${EPREFIX}"/etc/X11/Xloadimage
+}
+
+src_install() {
+ dobin xloadimage uufilter
+
+ dosym xloadimage /usr/bin/xsetbg
+ dosym xloadimage /usr/bin/xview
+
+ insinto /etc/X11
+ doins xloadimagerc
+
+ newman xloadimage.man xloadimage.1
+ newman uufilter.man uufilter.1
+
+ echo ".so man1/xloadimage.1" > "${T}"/xsetbg.1 || die
+ doman "${T}"/xsetbg.1
+ newman "${T}"/xsetbg.1 xview.1
+
+ dodoc README
+}