summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/xsvg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/xsvg')
-rw-r--r--media-gfx/xsvg/Manifest1
-rw-r--r--media-gfx/xsvg/files/xsvg-0.2.1-asneeded.patch9
-rw-r--r--media-gfx/xsvg/metadata.xml5
-rw-r--r--media-gfx/xsvg/xsvg-0.2.1.ebuild33
4 files changed, 48 insertions, 0 deletions
diff --git a/media-gfx/xsvg/Manifest b/media-gfx/xsvg/Manifest
new file mode 100644
index 000000000000..247cdfd2788e
--- /dev/null
+++ b/media-gfx/xsvg/Manifest
@@ -0,0 +1 @@
+DIST xsvg-0.2.1.tar.gz 91431 RMD160 c26af8139e87080b45b8b41556d984dc9fd3da8f SHA1 429d63ac35573177f8600353bc0a2e2030b4152f SHA256 af75bb7f5ab15310c34a1ca3d357c7f5210be6439a3a76047c44ad9f0a3c2d6f
diff --git a/media-gfx/xsvg/files/xsvg-0.2.1-asneeded.patch b/media-gfx/xsvg/files/xsvg-0.2.1-asneeded.patch
new file mode 100644
index 000000000000..aafe09893476
--- /dev/null
+++ b/media-gfx/xsvg/files/xsvg-0.2.1-asneeded.patch
@@ -0,0 +1,9 @@
+diff -ur xsvg-0.2.1.orig/src/Makefile.am xsvg-0.2.1/src/Makefile.am
+--- xsvg-0.2.1.orig/src/Makefile.am 2003-12-19 17:07:21.000000000 +0200
++++ xsvg-0.2.1/src/Makefile.am 2007-03-12 22:31:55.000000000 +0200
+@@ -6,4 +6,4 @@
+ xsvg.c
+
+ AM_CFLAGS = $(X_CFLAGS) $(XSVG_CFLAGS)
+-xsvg_LDFLAGS = $(X_LIBS) $(XSVG_LIBS)
++xsvg_LDADD = $(X_LIBS) $(XSVG_LIBS)
diff --git a/media-gfx/xsvg/metadata.xml b/media-gfx/xsvg/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/xsvg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/xsvg/xsvg-0.2.1.ebuild b/media-gfx/xsvg/xsvg-0.2.1.ebuild
new file mode 100644
index 000000000000..da41a89bb357
--- /dev/null
+++ b/media-gfx/xsvg/xsvg-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="a command line viewer for SVG files"
+HOMEPAGE="http://cairographics.org"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/cairo[X]
+ x11-libs/libsvg-cairo"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-libs/libXcursor"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}