summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-09-02 07:04:21 -0500
committerBen Kohler <bkohler@gentoo.org>2024-09-03 06:17:42 -0500
commit511a3b05560afbacf2d0b776bc3258efe07395b2 (patch)
treeaa5741da83a8884d02f6de057ee2f28cdb9cb171 /media-gfx/xv/xv-6.0.1.ebuild
parentmedia-radio/svxlink: Stabilize 24.02-r2 x86, #938735 (diff)
downloadgentoo-511a3b05560afbacf2d0b776bc3258efe07395b2.tar.gz
gentoo-511a3b05560afbacf2d0b776bc3258efe07395b2.tar.bz2
gentoo-511a3b05560afbacf2d0b776bc3258efe07395b2.zip
media-gfx/xv: add 6.0.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx/xv/xv-6.0.1.ebuild')
-rw-r--r--media-gfx/xv/xv-6.0.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/xv/xv-6.0.1.ebuild b/media-gfx/xv/xv-6.0.1.ebuild
new file mode 100644
index 000000000000..2983ac332da6
--- /dev/null
+++ b/media-gfx/xv/xv-6.0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop flag-o-matic xdg-utils
+
+JUMBOV=20070520
+DESCRIPTION="Interactive image manipulation program supporting a wide variety of formats"
+HOMEPAGE="https://github.com/jasper-software/xv/"
+SRC_URI="https://github.com/jasper-software/xv/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ mirror://gentoo/xv-3.10a.png.bz2"
+
+LICENSE="xv"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="jpeg tiff png webp"
+
+DEPEND="
+ x11-libs/libXt
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ tiff? ( media-libs/tiff:= )
+ png? (
+ >=media-libs/libpng-1.2:=
+ sys-libs/zlib
+ )
+ webp? ( media-libs/libwebp:= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/xv-5.2.0-osx-bsd.patch"
+)
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/859823
+ # https://github.com/jasper-software/xv/issues/25
+ filter-lto
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -DXV_ENABLE_JPEG=$(usex jpeg)
+ -DXV_ENABLE_JP2K=OFF
+ -DXV_ENABLE_PNG=$(usex png)
+ -DXV_ENABLE_TIFF=$(usex tiff)
+ -DXV_ENABLE_WEBP=$(usex webp)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newicon "${WORKDIR}"/xv-3.10a.png ${PN}.png
+ make_desktop_entry xv "" "" "Graphics;Viewer"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}