summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2024-01-12 00:02:37 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-12 14:32:04 +0100
commit364766449f46e6fef5bc47dd451700eeafd9345d (patch)
treeb85bdb417cbf987c0d183bc296fcf1024e8bdc1a /media-gfx
parentnet-firewall/ipset: drop 7.17 (diff)
downloadgentoo-364766449f46e6fef5bc47dd451700eeafd9345d.tar.gz
gentoo-364766449f46e6fef5bc47dd451700eeafd9345d.tar.bz2
gentoo-364766449f46e6fef5bc47dd451700eeafd9345d.zip
media-gfx/plantuml: add 1.2023.13
Signed-off-by: Alexey Zapparov <alexey@zapparov.com> Closes: https://github.com/gentoo/gentoo/pull/34769 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/plantuml/Manifest1
-rw-r--r--media-gfx/plantuml/plantuml-1.2023.13.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/plantuml/Manifest b/media-gfx/plantuml/Manifest
index feb538acfafc..2b97ae5070e8 100644
--- a/media-gfx/plantuml/Manifest
+++ b/media-gfx/plantuml/Manifest
@@ -1 +1,2 @@
DIST plantuml-1.2022.7.tar.gz 5438055 BLAKE2B 864bc3ac35082cae6ec52d8668572f5c116e8185695ad81d85977ec417b4f789d60538cb3f7d8b54398d28994fc4e60a4eebd33f600795ec2d1ca516c6c96719 SHA512 8e84efdb73ad864f61fbde2ea260ff2712276e91093a25096c1cae27d1256eb6697a05c1e3f2829a7fe34f1d1ab7854703976ed796d493c928b35df689eda492
+DIST plantuml-1.2023.13.tar.gz 11975624 BLAKE2B dc8792c1b47efe7d27fa4c870271da61d1efcae0554b036d81bc5e6ef27ae522683820d0979bef3f5114780585db4c79edd46199dbab871352fb5562ea2d3a91 SHA512 e0beff723887209971f42984759f04e07140e6e866e1bd9cb50b3e6eb3efbc39d3e1c10a48d7c07655562487e75563affdd616f4f0f50eb22bdf2574f0fa9f4a
diff --git a/media-gfx/plantuml/plantuml-1.2023.13.ebuild b/media-gfx/plantuml/plantuml-1.2023.13.ebuild
new file mode 100644
index 000000000000..0191ef13fcdb
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2023.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="https://plantuml.com"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ dev-java/ant-core:0
+ media-gfx/graphviz"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+
+ make_desktop_entry plantuml PlantUML
+}