summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-23 22:53:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-23 22:57:29 +0200
commit6853625c9ea324021f861e92b2aa94349ecc9240 (patch)
treeffdcf87c70bb05a898b7d76bf7f5cb030b54b7a0 /media-gfx
parentmedia-gfx/luminance-hdr: Fix build with media-gfx/exiv2-0.27.1 (diff)
downloadgentoo-6853625c9ea324021f861e92b2aa94349ecc9240.tar.gz
gentoo-6853625c9ea324021f861e92b2aa94349ecc9240.tar.bz2
gentoo-6853625c9ea324021f861e92b2aa94349ecc9240.zip
media-gfx/exiv2: Fix cmake module, link targets, use libssh-config
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/exiv2-0.27.1-r1.ebuild108
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.1-private-libs.patch59
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.1-restore-0.25-behaviour.patch119
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir1.patch41
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir2.patch28
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.1-system-libssh-config.patch93
6 files changed, 448 insertions, 0 deletions
diff --git a/media-gfx/exiv2/exiv2-0.27.1-r1.ebuild b/media-gfx/exiv2/exiv2-0.27.1-r1.ebuild
new file mode 100644
index 000000000000..8ffcb2c29e98
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.27.1-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ SRC_URI="https://exiv2.org/builds/${P}-Source.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://www.exiv2.org/"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+IUSE="doc examples nls +png webready +xmp"
+
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? (
+ net-libs/libssh[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+S="${S}-Source"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-cmakemoduledir{1,2}.patch
+ "${FILESDIR}"/${P}-private-libs.patch
+ "${FILESDIR}"/${P}-restore-0.25-behaviour.patch
+ "${FILESDIR}"/${P}-system-libssh-config.patch
+)
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ cmake-utils_src_prepare
+
+ sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_BUILD_PO=$(usex nls)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_SSH=$(usex webready)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && eninja doc
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}
diff --git a/media-gfx/exiv2/files/exiv2-0.27.1-private-libs.patch b/media-gfx/exiv2/files/exiv2-0.27.1-private-libs.patch
new file mode 100644
index 000000000000..c99a19098ae5
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.27.1-private-libs.patch
@@ -0,0 +1,59 @@
+From f05d100579effd7459fd0715b26239d4cd2c9bcc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Luis=20D=C3=ADaz=20M=C3=A1s?= <piponazo@gmail.com>
+Date: Sat, 4 May 2019 16:14:15 +0200
+Subject: [PATCH] CURL lib and include directories private for exiv2lib
+
+(cherry picked from commit 5d64a0b11c5a45dd9d58c56e946301f3f98942a7)
+---
+ samples/CMakeLists.txt | 14 ++++++++++++++
+ src/CMakeLists.txt | 10 +++++-----
+ 2 files changed, 19 insertions(+), 5 deletions(-)
+
+diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
+index a82403e3b..c3f4722df 100644
+--- a/samples/CMakeLists.txt
++++ b/samples/CMakeLists.txt
+@@ -96,6 +96,20 @@ endif()
+ add_executable(conntest conntest.cpp)
+ list(APPEND APPLICATIONS conntest)
+
++if (EXIV2_ENABLE_WEBREADY)
++ if( EXIV2_ENABLE_CURL )
++ target_include_directories(conntest SYSTEM PRIVATE ${CURL_INCLUDE_DIR} )
++ target_link_libraries(conntest PRIVATE ${CURL_LIBRARIES})
++ if (USING_CONAN)
++ target_compile_definitions(conntest PRIVATE ${CONAN_COMPILE_DEFINITIONS_LIBCURL})
++ target_link_libraries(conntest PRIVATE ${CONAN_EXE_LINKER_FLAGS_LIBCURL})
++ if (NOT APPLE)
++ target_link_libraries(conntest PRIVATE CONAN_PKG::OpenSSL)
++ endif()
++ endif()
++ endif()
++endif()
++
+ # ******************************************************************************
+ # remotetest application
+ add_executable(remotetest remotetest.cpp)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 976327775..d0e989d26 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -179,13 +179,13 @@ if (EXIV2_ENABLE_WEBREADY)
+ endif()
+
+ if( EXIV2_ENABLE_CURL )
+- target_include_directories(exiv2lib SYSTEM PUBLIC ${CURL_INCLUDE_DIR} )
+- target_link_libraries(exiv2lib PUBLIC ${CURL_LIBRARIES})
++ target_include_directories(exiv2lib SYSTEM PRIVATE ${CURL_INCLUDE_DIR} )
++ target_link_libraries(exiv2lib PRIVATE ${CURL_LIBRARIES})
+ if (USING_CONAN)
+- target_compile_definitions(exiv2lib PUBLIC ${CONAN_COMPILE_DEFINITIONS_LIBCURL})
+- target_link_libraries(exiv2lib PUBLIC ${CONAN_EXE_LINKER_FLAGS_LIBCURL})
++ target_compile_definitions(exiv2lib PRIVATE ${CONAN_COMPILE_DEFINITIONS_LIBCURL})
++ target_link_libraries(exiv2lib PRIVATE ${CONAN_EXE_LINKER_FLAGS_LIBCURL})
+ if (NOT APPLE)
+- target_link_libraries(exiv2lib PUBLIC CONAN_PKG::OpenSSL)
++ target_link_libraries(exiv2lib PRIVATE CONAN_PKG::OpenSSL)
+ endif()
+ endif()
+ endif()
diff --git a/media-gfx/exiv2/files/exiv2-0.27.1-restore-0.25-behaviour.patch b/media-gfx/exiv2/files/exiv2-0.27.1-restore-0.25-behaviour.patch
new file mode 100644
index 000000000000..2aa4d3a826f3
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.27.1-restore-0.25-behaviour.patch
@@ -0,0 +1,119 @@
+From db870755b928cca7411a092ce12292afe9c4fa36 Mon Sep 17 00:00:00 2001
+From: clanmills <robin@clanmills.com>
+Date: Thu, 9 May 2019 11:26:29 +0100
+Subject: [PATCH] fix #818. Restore 0.25 behaviour of `$ exiv2 -g image ...`
+ to apply grep to keys.
+
+---
+ src/actions.cpp | 2 +-
+ src/exiv2.1 | 50 +++++++++++++++++--------
+ tests/bugfixes/github/test_issue_818.py | 32 ++++++++++++++++
+ 3 files changed, 67 insertions(+), 17 deletions(-)
+ create mode 100644 tests/bugfixes/github/test_issue_818.py
+
+diff --git a/src/actions.cpp b/src/actions.cpp
+index 34a7a80d5..68260186d 100644
+--- a/src/actions.cpp
++++ b/src/actions.cpp
+@@ -243,7 +243,7 @@ namespace Action {
+ int rc = 0;
+ Exiv2::PrintStructureOption option = Exiv2::kpsNone ;
+ switch (Params::instance().printMode_) {
+- case Params::pmSummary: rc = printSummary(); break;
++ case Params::pmSummary: rc = Params::instance().greps_.empty() ? printSummary() : printList(); break;
+ case Params::pmList: rc = printList(); break;
+ case Params::pmComment: rc = printComment(); break;
+ case Params::pmPreview: rc = printPreviewList(); break;
+diff --git a/src/exiv2.1 b/src/exiv2.1
+index 4f6f3b51b..048f09af7 100644
+--- a/src/exiv2.1
++++ b/src/exiv2.1
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH EXIV2 1 "Apr 25, 2019"
++.TH EXIV2 1 "May 8, 2019"
+ .\" Please adjust this date whenever revising the manpage.
+ .\"
+ .\" Some roff macros, for reference:
+@@ -222,19 +222,30 @@ Show unknown tags (default is to suppress tags which don't have a name).
+ Only keys which match the given key (grep).
+ .br
+ Multiple \fB\-g\fP options
+-can be used to grep info for several keys. Example:
++can be used to filter info to less keys. Example:
+ exiv2 -v -V -g webready -g time.
++The default exiv2 command prints a "summary report" which is quite short. When you use -g without a -pmod option, you do not get a summary report and in effect you get -g pattern -pa image ...
+
+ .nf
+-exiv2 \-g Date \-pt R.jpg
+-Exif.Image.DateTime Ascii 20 2012:08:07 16:01:05
+-Exif.Photo.DateTimeOriginal Ascii 20 2011:09:18 16:25:48
+-Exif.Photo.DateTimeDigitized Ascii 20 2011:09:18 16:25:48
++$ bin/exiv2 -g Date http://clanmills.com/Stonehenge.jpg
++Exif.Image.DateTime Ascii 20 2015:07:16 20:25:28
++Exif.Photo.DateTimeOriginal Ascii 20 2015:07:16 15:38:54
++Exif.Photo.DateTimeDigitized Ascii 20 2015:07:16 15:38:54
++Exif.NikonWt.DateDisplayFormat Byte 1 Y/M/D
++Exif.GPSInfo.GPSDateStamp Ascii 11 2015:07:16
++Xmp.xmp.ModifyDate XmpText 25 2015-07-16T20:25:28+01:00
+
+ .fi
+--g (--grep) is only applied to keys. It is not generally applied to all output such as the default -ps report.
++You may use -pmod filters to further filter output. For example:
++.nf
++
++$ bin/exiv2 -px -g Date http://clanmills.com/Stonehenge.jpg
++Xmp.xmp.ModifyDate XmpText 25 2015-07-16T20:25:28+01:00
+
+-The key may finish with the optional modifier /i to indicated case insensitive.
++.fi
++The option -g (--grep) applies to keys and not values.
++
++The key may finish with the optional modifier /i to indicate case insensitive.
+ .TP
+ .B \-K \fIkey\fP
+ Only report data for given key.
+@@ -243,8 +254,8 @@ Multiple \fB\-K\fP options can be used to report more than a single key.
+
+ .nf
+ exiv2 \-K Exif.Photo.DateTimeDigitized -K Exif.Photo.DateTimeOriginal \-pt R.jpg
+-Exif.Photo.DateTimeOriginal Ascii 20 2011:09:18 16:25:48
+-Exif.Photo.DateTimeDigitized Ascii 20 2011:09:18 16:25:48
++Exif.Photo.DateTimeOriginal Ascii 20 2011:09:18 16:25:48
++Exif.Photo.DateTimeDigitized Ascii 20 2011:09:18 16:25:48
+ .fi
+ .TP
+ .B \-n \fIenc\fP
+@@ -594,17 +605,24 @@ You obtain the lensID for your camera with the command:
+ .nf
+ .sp 1
+ $ exiv2 -pv --grep lens/i http://clanmills.com/Stonehenge.jpg
+-0x0083 Nikon3 LensType Byte 1 14
+-0x0084 Nikon3 Lens Rational 4 180/10 2500/10 35/10 63/10
+-0x008b Nikon3 LensFStops Undefined 4 55 1 12 0
+-0x000c NikonLd3 LensIDNumber Byte 1 146 <--- This number
+-0x000d NikonLd3 LensFStops Byte 1 55
++0x0083 Nikon3 LensType Byte 1 14
++0x0084 Nikon3 Lens Rational 4 180/10 2500/10 35/10 63/10
++0x008b Nikon3 LensFStops Undefined 4 55 1 12 0
++0x000c NikonLd3 LensIDNumber Byte 1 146 <--- This number
++0x000d NikonLd3 LensFStops Byte 1 55
+ .br
+ .ne 40
+ .SH EXAMPLES
+ .TP
+ exiv2 *.jpg
+-Prints a summary of the Exif information for all JPEG files in the directory.
++Prints a summary of the Exif information for all JPEG files in the directory. The summary report is rather brief and presentation does not use the Family.Group.Tag convention.
++
++If you use --grep pattern, the default becomes -pa. See -g/grep above.
++
++.nf
++$ exiv2 -g Date http://clanmills.com/Stonehenge.jpg
++
++.fi
+ .TP
+ exiv2 \-pi image.jpg
+ Prints the IPTC metadata of the image.
diff --git a/media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir1.patch b/media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir1.patch
new file mode 100644
index 000000000000..77a68437502e
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir1.patch
@@ -0,0 +1,41 @@
+From 78676b2a025023ab3de2d094e0798ed64ef7df97 Mon Sep 17 00:00:00 2001
+From: Robin Mills <robin@clanmills.com>
+Date: Sat, 27 Apr 2019 11:18:22 +0100
+Subject: [PATCH] Fix #798
+
+---
+ README.md | 2 +-
+ releasenotes/CYGWIN/ReadMe.txt | 17 +----------------
+ releasenotes/Darwin/ReadMe.txt | 6 ++----
+ releasenotes/Linux/ReadMe.txt | 2 +-
+ releasenotes/MinGW/ReadMe.txt | 2 +-
+ releasenotes/msvc/ReadMe.txt | 2 +-
+ src/CMakeLists.txt | 2 +-
+ 7 files changed, 8 insertions(+), 25 deletions(-)
+
+diff --git a/README.md b/README.md
+index 6e9f50a94..92cca39e6 100644
+--- a/README.md
++++ b/README.md
+@@ -189,7 +189,7 @@ project(exifprint VERSION 0.0.1 LANGUAGES CXX)
+ set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_EXTENSIONS OFF)
+
+-find_package(exiv2 REQUIRED CONFIG NAMES exiv2) # search ${CMAKE_INSTALL_PREFIX}/lib/exiv2/cmake/
++find_package(exiv2 REQUIRED CONFIG NAMES exiv2) # search ${CMAKE_INSTALL_PREFIX}/lib/cmake/exiv2
+ add_executable(exifprint ../samples/exifprint.cpp) # compile this
+ target_link_libraries(exifprint exiv2lib) # link exiv2lib
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 340870048..976327775 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -239,7 +239,7 @@ install(FILES
+ ${CMAKE_BINARY_DIR}/exiv2lib_export.h
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/exiv2)
+
+-install(EXPORT exiv2Config DESTINATION "${CMAKE_INSTALL_LIBDIR}/exiv2/cmake")
++install(EXPORT exiv2Config DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/exiv2")
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2ConfigVersion.cmake DESTINATION "${CMAKE_INSTALL_LIBDIR}/exiv2/cmake")
+
diff --git a/media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir2.patch b/media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir2.patch
new file mode 100644
index 000000000000..1770449564a2
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.27.1-system-cmakemoduledir2.patch
@@ -0,0 +1,28 @@
+From 6819f2ac456c57291f94cc1f4db13ce134eed468 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 23 Jun 2019 19:32:29 +0200
+Subject: [PATCH] Fix install path of exiv2ConfigVersion.cmake
+
+This seems to have been caused by duplicate work between master branch
+and 0.27-maintenance branch, as commit 3b48249eeb350301dfb3efa3ba6f7d7b162455be
+had already got that right.
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1d0ccee4..05ce4e14 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -245,7 +245,7 @@ install(FILES
+
+ install(EXPORT exiv2Config DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/exiv2")
+
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2ConfigVersion.cmake DESTINATION "${CMAKE_INSTALL_LIBDIR}/exiv2/cmake")
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/exiv2ConfigVersion.cmake DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/exiv2")
+
+ # ******************************************************************************
+ # exiv2 application
+--
+2.22.0
+
diff --git a/media-gfx/exiv2/files/exiv2-0.27.1-system-libssh-config.patch b/media-gfx/exiv2/files/exiv2-0.27.1-system-libssh-config.patch
new file mode 100644
index 000000000000..555314ae9329
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.27.1-system-libssh-config.patch
@@ -0,0 +1,93 @@
+From e85ce17fc91e11eff26c6f5a89125505b7db5fd3 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 23 Jun 2019 19:50:01 +0200
+Subject: [PATCH 1/2] Switch to libssh's own libssh-config.cmake
+
+This is provided by libssh since 2013.
+---
+ cmake/findDependencies.cmake | 2 +-
+ src/CMakeLists.txt | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/findDependencies.cmake b/cmake/findDependencies.cmake
+index 12d47525..52760185 100644
+--- a/cmake/findDependencies.cmake
++++ b/cmake/findDependencies.cmake
+@@ -20,7 +20,7 @@ if( EXIV2_ENABLE_WEBREADY )
+ endif()
+
+ if( EXIV2_ENABLE_SSH )
+- find_package( SSH REQUIRED)
++ find_package(libssh CONFIG REQUIRED)
+ endif( )
+ endif( )
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1d0ccee4..b532fc7b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -174,8 +174,8 @@ target_include_directories(exiv2lib_int PUBLIC
+ if (EXIV2_ENABLE_WEBREADY)
+
+ if( EXIV2_ENABLE_SSH )
+- target_include_directories(exiv2lib SYSTEM PUBLIC ${SSH_INCLUDE_DIR} )
+- target_link_libraries( exiv2lib PUBLIC ${SSH_LIBRARIES})
++ target_include_directories(exiv2lib SYSTEM PUBLIC ${LIBSSH_INCLUDE_DIR})
++ target_link_libraries(exiv2lib PUBLIC ${LIBSSH_LIBRARIES})
+ endif()
+
+ if( EXIV2_ENABLE_CURL )
+--
+2.22.0
+
+
+From 89d8160a410c2c526ad021fd456accc709cae520 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 23 Jun 2019 19:50:44 +0200
+Subject: [PATCH 2/2] Drop now obsolete FindSSH.cmake
+
+---
+ cmake/FindSSH.cmake | 31 -------------------------------
+ 1 file changed, 31 deletions(-)
+ delete mode 100644 cmake/FindSSH.cmake
+
+diff --git a/cmake/FindSSH.cmake b/cmake/FindSSH.cmake
+deleted file mode 100644
+index 2a6fa378..00000000
+--- a/cmake/FindSSH.cmake
++++ /dev/null
+@@ -1,31 +0,0 @@
+-# - Find libssh
+-# Find the native SSH headers and libraries.
+-#
+-# SSH_INCLUDE_DIRS - where to find libssh.h, etc.
+-# SSH_LIBRARIES - List of libraries when using libssh.
+-# SSH_FOUND - True if libssh found.
+-#
+-# Redistribution and use is allowed according to the terms of the BSD license.
+-# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+-
+-# Look for the header file.
+-FIND_PATH(SSH_INCLUDE_DIR NAMES libssh/libssh.h)
+-
+-# Look for the library.
+-FIND_LIBRARY(SSH_LIBRARY NAMES ssh libssh)
+-
+-# handle the QUIETLY and REQUIRED arguments and set SSH_FOUND to TRUE if
+-# all listed variables are TRUE
+-INCLUDE(FindPackageHandleStandardArgs)
+-FIND_PACKAGE_HANDLE_STANDARD_ARGS(SSH DEFAULT_MSG SSH_LIBRARY SSH_INCLUDE_DIR)
+-
+-# Copy the results to the output variables.
+-IF(SSH_FOUND)
+- SET(SSH_LIBRARIES ${SSH_LIBRARY})
+- SET(SSH_INCLUDE_DIRS ${SSH_INCLUDE_DIR})
+-ELSE(SSH_FOUND)
+- SET(SSH_LIBRARIES)
+- SET(SSH_INCLUDE_DIRS)
+-ENDIF(SSH_FOUND)
+-
+-MARK_AS_ADVANCED(SSH_INCLUDE_DIR SSH_LIBRARY)
+--
+2.22.0
+