summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-12 10:33:30 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-12 10:34:29 -0800
commit6ada5390422e4bd91e1f51272c5a2dbef1622ed2 (patch)
tree38a46c06f0c05d62a344b52266d7974dd1e83c0c /media-gfx
parentdev-ml/camlzip: respect ocamlopt (diff)
downloadgentoo-6ada5390422e4bd91e1f51272c5a2dbef1622ed2.tar.gz
gentoo-6ada5390422e4bd91e1f51272c5a2dbef1622ed2.tar.bz2
gentoo-6ada5390422e4bd91e1f51272c5a2dbef1622ed2.zip
media-gfx/brscan4: Version bump to 0.4.11.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/brscan4/Manifest2
-rw-r--r--media-gfx/brscan4/brscan4-0.4.11.1.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/brscan4/Manifest b/media-gfx/brscan4/Manifest
index 04480576375d..6159eff2e71e 100644
--- a/media-gfx/brscan4/Manifest
+++ b/media-gfx/brscan4/Manifest
@@ -1,2 +1,4 @@
DIST brscan4-0.4.10-1.i386.rpm 100151 BLAKE2B 94fd7daa5682b294740a6e1345c4ab8d488589896c3fa34eafc131b1cdc2ef2e022e11795ebc261538c6107583602a9622946ea049a3cfbbeb547e7e9c8825ad SHA512 5daeb9a1304f3aeb0a2e17823887a546ff872dfb42bf08ab403539815553da597504ac7afcbb2a34fbcfd8d973c03c8ca2c62617f8c499b9fc44b1719e4f2611
DIST brscan4-0.4.10-1.x86_64.rpm 118863 BLAKE2B 1e518122b049a6cd594e4603311d37f289aef4ad3973cbe846700c2a5c0c8f0ec994f6608817a1c12d6494c3ae78178b43f4ba8450ab00153e27f533ec1957c8 SHA512 c648db8d8543dec9e1cd556f2e0415c170c06935febd1373d783191b159ed9ed67043644ef81fb18027de89270e10a5cedcee11ea66ee262df1a2d4f006e4875
+DIST brscan4-0.4.11-1.i386.rpm 100453 BLAKE2B d3801d208faf203700a6723619b1999722225400c135c7c5e6cc3cfd8a963375c2094d518ae2d18be0e0d0fbff96b238de5fd89bfc82baad5bef25b1e9b83c25 SHA512 0c07311b2f7e728f876b52d3da1473942487d4ce7dfd65d3c7aef8ff2321ac1a1e904446a60738e38722217af35d9d6455ab2bb390305da8a3c548fb024f0b70
+DIST brscan4-0.4.11-1.x86_64.rpm 119016 BLAKE2B 9b43c1e10e5e0ee63b89999390d214d71f694c885749401ac676999ffabfcc24174098b09586bd148144dd6e83f89c52c251be293e428edf0f70b964d5d5042c SHA512 c97a7f51398e34783a7099a118bad320b01e220f6ba942504194d6d2e5e10164168594820232f3861458916be1985ed23560b9b635d2755f03551c663768ebf7
diff --git a/media-gfx/brscan4/brscan4-0.4.11.1.ebuild b/media-gfx/brscan4/brscan4-0.4.11.1.ebuild
new file mode 100644
index 000000000000..7473ad81942d
--- /dev/null
+++ b/media-gfx/brscan4/brscan4-0.4.11.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eapi8-dosym readme.gentoo-r1 rpm
+
+MY_P="${PN}-${PV%.*}-${PV##*.}"
+DESCRIPTION="Brother scanner driver"
+HOMEPAGE="https://www.brother.com/"
+SRC_URI="
+ amd64? ( https://download.brother.com/welcome/dlf105203/${MY_P}.x86_64.rpm )
+ x86? ( https://download.brother.com/welcome/dlf105202/${MY_P}.i386.rpm )"
+S="${WORKDIR}/opt/brother/scanner/${PN}"
+
+LICENSE="Brother"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="zeroconf"
+RESTRICT="strip"
+
+RDEPEND="media-gfx/sane-backends
+ virtual/libusb:0
+ zeroconf? ( net-dns/avahi )"
+
+QA_PREBUILT="opt/brother/*"
+
+src_install() {
+ local dest=/opt/brother/scanner/${PN}
+ local lib=$(get_libdir)
+
+ insinto /etc${dest}
+ doins Brsane4.ini brsanenetdevice4.cfg
+ doins -r models4
+ dosym8 -r {/etc,}${dest}/Brsane4.ini
+ dosym8 -r {/etc,}${dest}/brsanenetdevice4.cfg
+ dosym8 -r {/etc,}${dest}/models4
+
+ exeinto ${dest}
+ doexe brsaneconfig4
+ dosym8 -r {${dest},/usr/bin}/brsaneconfig4
+
+ if use zeroconf; then
+ doexe brscan_cnetconfig
+ # Don't install brscan_gnetconfig because it depends on gtk+:2
+ fi
+
+ into ${dest}
+ dolib.so "${WORKDIR}"/usr/${lib}/sane/libsane-brother4.so.1.0.7
+ dosym libsane-brother4.so.1.0.7 ${dest}/${lib}/libsane-brother4.so.1
+ dosym libsane-brother4.so.1.0.7 ${dest}/${lib}/libsane-brother4.so
+ dosym8 -r {${dest}/${lib},/usr/${lib}/sane}/libsane-brother4.so.1.0.7
+ dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so.1
+ dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so
+
+ insinto /etc/sane.d/dll.d
+ newins - ${PN} <<< "brother4"
+
+ local DOC_CONTENTS="If want to use a remote scanner over the network,
+ you will have to add it with \"brsaneconfig4\"."
+ use zeroconf || DOC_CONTENTS+="\\n\\nNote that querying the network
+ (\"brsaneconfig4 -q\") will not work unless you emerge ${PN} with
+ the zeroconf flag enabled."
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}