summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <sebastian@blender.org>2024-11-29 16:31:19 +0100
committerSam James <sam@gentoo.org>2024-12-01 08:33:33 +0000
commitbdaf73a9d0c58af341407e8197d43f9bfd12f13e (patch)
treefc7d4d71c99772b21584253937fb58d8e96dcedc /media-gfx
parentmedia-gfx/blender: Remove the experimental option (diff)
downloadgentoo-bdaf73a9d0c58af341407e8197d43f9bfd12f13e.tar.gz
gentoo-bdaf73a9d0c58af341407e8197d43f9bfd12f13e.tar.bz2
gentoo-bdaf73a9d0c58af341407e8197d43f9bfd12f13e.zip
media-gfx/blender: Fix building docs
Closes: https://bugs.gentoo.org/939103 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/blender/blender-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/media-gfx/blender/blender-9999.ebuild b/media-gfx/blender/blender-9999.ebuild
index 5a901ba720f6..b062e630b1a5 100644
--- a/media-gfx/blender/blender-9999.ebuild
+++ b/media-gfx/blender/blender-9999.ebuild
@@ -479,15 +479,16 @@ src_test() {
DESTDIR="${T}" cmake_build install
blender_get_version
- # Define custom blender data/script file paths not be able to find them otherwise during testing.
- # (Because the data is in the image directory and it will default to look in /usr/share)
- export BLENDER_SYSTEM_SCRIPTS="${T}/usr/share/blender/${BV}/scripts"
- export BLENDER_SYSTEM_DATAFILES="${T}/usr/share/blender/${BV}/datafiles"
+ # By default, blender will look for system scripts and data in
+ # /usr/share/, but until this is installed, they are not necessarily
+ # available there. Use this to have blender search the intermediate
+ # install directory instead.
+ export BLENDER_SYSTEM_RESOURCES="${T}/usr/share/blender/${BV}"
- # Sanity check that the script and datafile path is valid.
- # If they are not vaild, blender will fallback to the default path which is not what we want.
- [ -d "$BLENDER_SYSTEM_SCRIPTS" ] || die "The custom script path is invalid, fix the ebuild!"
- [ -d "$BLENDER_SYSTEM_DATAFILES" ] || die "The custom datafiles path is invalid, fix the ebuild!"
+ # Brake check: Make sure the above path is valid.
+ # If not, blender will fallback to the default path which is not what
+ # we want.
+ [ -d "$BLENDER_SYSTEM_RESOURCES" ] || die "The custom script path is invalid, fix the ebuild!"
if use cuda; then
cuda_add_sandbox -w
@@ -521,10 +522,16 @@ src_install() {
fi
if use doc; then
- # Define custom blender data/script file paths. Otherwise Blender will not be able to find them during doc building.
- # (Because the data is in the image directory and it will default to look in /usr/share)
- export BLENDER_SYSTEM_SCRIPTS=${ED}/usr/share/blender/${BV}/scripts
- export BLENDER_SYSTEM_DATAFILES=${ED}/usr/share/blender/${BV}/datafiles
+ # By default, blender will look for system scripts and data in
+ # /usr/share/, but until this is installed, they are not necessarily
+ # available there. Use this to have blender search the intermediate
+ # install directory instead.
+ export BLENDER_SYSTEM_RESOURCES="${ED}/usr/share/blender/${BV}"
+
+ # Brake check: Make sure the above path is valid.
+ # If not, blender will fallback to the default path which is not what
+ # we want.
+ [ -d "$BLENDER_SYSTEM_RESOURCES" ] || die "The custom script path is invalid, fix the ebuild!"
# Workaround for binary drivers.
addpredict /dev/ati