summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-27 22:54:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 12:48:47 +0100
commit9442a594090d26bdb67baeccf9d1e48913aafa60 (patch)
tree16a6d6d9ac4494ae925635d39fa45ef4377bf485 /media-libs/avidemux-core
parentmedia-libs/avidemux-plugins: drop 2.7.8 (diff)
downloadgentoo-9442a594090d26bdb67baeccf9d1e48913aafa60.tar.gz
gentoo-9442a594090d26bdb67baeccf9d1e48913aafa60.tar.bz2
gentoo-9442a594090d26bdb67baeccf9d1e48913aafa60.zip
media-libs/avidemux-core: drop 2.7.8
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/avidemux-core')
-rw-r--r--media-libs/avidemux-core/Manifest1
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.7.8.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/media-libs/avidemux-core/Manifest b/media-libs/avidemux-core/Manifest
index 5e1a60fccafb..49e9b54b3bbf 100644
--- a/media-libs/avidemux-core/Manifest
+++ b/media-libs/avidemux-core/Manifest
@@ -1,2 +1 @@
-DIST avidemux-2.7.8.tar.gz 22080267 BLAKE2B a1e56856f44d56afac6ea4015f206a3f9301c025b3c8da1528165bd4c139ccc971074ac21aa05b9b3dfd6d514eabcbb375e671c8df9c9e5cae74a0a6597577c4 SHA512 6cd5527ab34517a07bf73e46d01f15b7ff023ff34ed70ee54f1d7dbfb6cf57364a323b4ecb89bb9aadeb9bc05473aacb40d8c4eecc522840a3c1c4b3a8756d82
DIST avidemux-2.8.1.tar.gz 23207741 BLAKE2B 766ae9b159d2e48a3d14bdfccf9c665b95ed056831b515d53837bf2bae20baf9b01d15d551b62fb96f3c0cf50b0138448a133bc62e6202af744de558e0fbfe4f SHA512 e7105e555e04dd6768336bdb246037e91045de2e1f572ae362d985424def65499c7f25d92d376ea98af09b436d89e9eb4a5424e93b11df14f2d67ac35661a8a3
diff --git a/media-libs/avidemux-core/avidemux-core-2.7.8.ebuild b/media-libs/avidemux-core/avidemux-core-2.7.8.ebuild
deleted file mode 100644
index 062fa0231f9c..000000000000
--- a/media-libs/avidemux-core/avidemux-core-2.7.8.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_MAKEFILE_GENERATOR="emake"
-
-inherit cmake flag-o-matic toolchain-funcs
-
-DESCRIPTION="Core libraries for simple video cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-SRC_URI="https://github.com/mean00/avidemux2/archive/${PV}.tar.gz -> avidemux-${PV}.tar.gz"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.7"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug nls sdl system-ffmpeg vaapi vdpau xv"
-
-# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
-DEPEND="
- dev-db/sqlite:3
- sdl? ( media-libs/libsdl:0 )
- system-ffmpeg? ( >=media-video/ffmpeg-9:0[mp3,theora] )
- vaapi? ( media-libs/libva:0= )
- vdpau? ( x11-libs/libvdpau:0 )
- xv? ( x11-libs/libXv:0 )
-"
-RDEPEND="
- ${DEPEND}
- !<media-libs/avidemux-core-${PV}
- !<media-video/avidemux-${PV}
- nls? ( virtual/libintl:0 )
-"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- !system-ffmpeg? ( dev-lang/yasm[nls=] )
-"
-
-PATCHES=( "${FILESDIR}"/avidemux-core-2.7.6-ffmpeg-flags.patch )
-
-S="${WORKDIR}/avidemux2-${PV}"
-CMAKE_USE_DIR="${S}/${PN/-/_}"
-
-src_prepare() {
- cmake_src_prepare
-
- if use system-ffmpeg ; then
- # Preparations to support the system ffmpeg. Currently fails because
- # it depends on files the system ffmpeg doesn't install.
- local error="Failed to remove bundled ffmpeg."
-
- rm -r cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
- sed -e 's/include(admFFmpegUtil)//g' -e '/registerFFmpeg/d' -i avidemux/commonCmakeApplication.cmake || die "${error}"
- sed -e 's/include(admFFmpegBuild)//g' -i avidemux_core/CMakeLists.txt || die "${error}"
- else
- local ffmpeg_args=(
- --cc=$(tc-getCC)
- --cxx=$(tc-getCXX)
- --ar=$(tc-getAR)
- --nm=$(tc-getNM)
- --ranlib=$(tc-getRANLIB)
- "--optflags='${CFLAGS}'"
- )
-
- sed -i -e "s/@@GENTOO_FFMPEG_FLAGS@@/${ffmpeg_args[*]}/" cmake/ffmpeg_configure.sh.cmake || die
- fi
-}
-
-src_configure() {
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
- # Bug 768210
- append-cxxflags -std=gnu++14
-
- local mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR='${S}'
- -DGETTEXT="$(usex nls)"
- -DNVENC=no
- -DSDL="$(usex sdl)"
- -DLIBVA="$(usex vaapi)"
- -DVDPAU="$(usex vdpau)"
- -DXVIDEO="$(usex xv)"
- )
-
- use debug && mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-}
-
-src_install() {
- cmake_src_install
-}