summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/babl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/Manifest2
-rw-r--r--media-libs/babl/babl-0.1.10-r1.ebuild65
-rw-r--r--media-libs/babl/babl-0.1.12.ebuild54
-rw-r--r--media-libs/babl/babl-9999.ebuild54
-rw-r--r--media-libs/babl/files/babl-0.1.10-clang.patch50
-rw-r--r--media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch12
-rw-r--r--media-libs/babl/files/babl-0.1.10-introspection.patch25
-rw-r--r--media-libs/babl/metadata.xml7
8 files changed, 269 insertions, 0 deletions
diff --git a/media-libs/babl/Manifest b/media-libs/babl/Manifest
new file mode 100644
index 000000000000..b8463b932da6
--- /dev/null
+++ b/media-libs/babl/Manifest
@@ -0,0 +1,2 @@
+DIST babl-0.1.10.tar.bz2 449537 SHA256 943fc36ceac7dd25bc928256bc7b535a42989c6b971578146869eee5fe5955f4 SHA512 2950d94c255ee05d405e003a46138da0f4e0cad65e2d2a882089b788c2deac0524014f7c5758c3097253bdbebaded433caf0447c7d218c9cc96798df9e6f0c92 WHIRLPOOL a71907a531bc71c7ac0c84a197a559c50321a5d96b5d846083935390890ef116780d49bd458577aef0e948395dc14897e6fbbc75478b2a59d57d4381cf7f8db8
+DIST babl-0.1.12.tar.bz2 642234 SHA256 2f802b7f1a17b72c10bf0fe1e69b7a888cf7ce62b7cf1537b030f7f88d55a407 SHA512 b69c8e3870f25372b2223aa4a716383af30342822461fc847039af964cdd194603dbc327a5c3547369d64b206b54280a5a9a227197ca6b7bcfbfa8e2e560df6a WHIRLPOOL b1a170492f1c1e6f030f418cc66c3be02cd2bd7e10896a416b5feaf2d7aa82de4fa15c9d2a65e6e1038ab6822e4dc3333f96102e18d757a6b1e07f4017b4beba
diff --git a/media-libs/babl/babl-0.1.10-r1.ebuild b/media-libs/babl/babl-0.1.10-r1.ebuild
new file mode 100644
index 000000000000..8b272d35c3ac
--- /dev/null
+++ b/media-libs/babl/babl-0.1.10-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# vala and introspection support is broken, bug #468208
+#VALA_MIN_API_VERSION=0.14
+#VALA_USE_DEPEND=vapigen
+
+inherit autotools eutils #vala
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_mmx" # +introspection vala
+
+RDEPEND=""
+#introspection? ( >=dev-libs/gobject-introspection-0.10 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+"
+#vala? ( $(vala_depend) )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-clang.patch
+
+ # fix compilation on OSX, can be dropped on next release:
+ # http://mail.gnome.org/archives/commits-list/2012-April/msg02589.html
+ sed -i -e 's/values\.h/limits.h/' babl/babl-palette.c || die
+ epatch "${FILESDIR}"/${P}-introspection.patch
+ epatch "${FILESDIR}"/${P}-g-ir-compiler-crash.patch
+ eautoreconf
+
+# use vala && vala_src_prepare
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-static \
+ --disable-maintainer-mode \
+ --disable-introspection \
+ --without-vala \
+ $(use_enable altivec) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse)
+# $(use_enable introspection) \
+# $(use_with vala)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS
+}
diff --git a/media-libs/babl/babl-0.1.12.ebuild b/media-libs/babl/babl-0.1.12.ebuild
new file mode 100644
index 000000000000..407941b467c3
--- /dev/null
+++ b/media-libs/babl/babl-0.1.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.gnome.org/babl"
+ SRC_URI=""
+else
+ SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="alpha ~amd64 arm hppa ~ia64 ~mips ppc ppc64 sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_mmx"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-docs \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse sse2)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/babl/babl-9999.ebuild b/media-libs/babl/babl-9999.ebuild
new file mode 100644
index 000000000000..ce739efbe576
--- /dev/null
+++ b/media-libs/babl/babl-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.gnome.org/babl"
+ SRC_URI=""
+else
+ SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_mmx"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-docs \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse sse2)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/babl/files/babl-0.1.10-clang.patch b/media-libs/babl/files/babl-0.1.10-clang.patch
new file mode 100644
index 000000000000..68e89d30d71d
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-clang.patch
@@ -0,0 +1,50 @@
+From 16492300a39e75e1015a0ab33e22b1e3f605c5ce Mon Sep 17 00:00:00 2001
+From: Michael Muré <batolettre@gmail.com>
+Date: Tue, 22 May 2012 03:48:44 +0000
+Subject: sse-fixups: use more portable functions to help compile with clang
+
+Original patch found here
+http://www.freebsd.org/cgi/cvsweb.cgi/ports/x11/babl/files/patch-sse-fixups.c?rev=1.1;content-type=text%2Fplain
+
+CVS tags: RELEASE_8_3_0, HEAD
+
+Fix the build with clang.
+
+PR: ports/163518
+Submitted by: Jan Beich <jbeich@tormail.net>
+Feature safe: yes
+---
+(limited to 'extensions/sse-fixups.c')
+
+diff --git a/extensions/sse-fixups.c b/extensions/sse-fixups.c
+index fdcc06f..95f1cc8 100644
+--- a/extensions/sse-fixups.c
++++ b/extensions/sse-fixups.c
+@@ -23,6 +23,8 @@
+
+ #if defined(__GNUC__) && (__GNUC__ >= 4) && defined(USE_SSE) && defined(USE_MMX)
+
++#include <xmmintrin.h>
++
+ #include <stdint.h>
+ #include <stdlib.h>
+
+@@ -40,11 +42,11 @@ typedef int g2int __attribute__ ((vector_size (2*sizeof(int))));
+ #define g4float_zero g4float_all(0.0)
+ #define g4float_ff g4float_all(255.0)
+
+-#define g4float_max(a,b) __builtin_ia32_maxps(a, b)
+-#define g4float_min(a,b) __builtin_ia32_minps(a, b)
+-#define g4float_cvt2pi(a) __builtin_ia32_cvtps2pi(a)
+-#define g4float_movhl(a,b) __builtin_ia32_movhlps(a, b)
+-#define g4float_emms __builtin_ia32_emms
++#define g4float_max(a,b) _mm_max_ps(a, b)
++#define g4float_min(a,b) _mm_min_ps(a, b)
++#define g4float_cvt2pi(a) _mm_cvtps_pi32(a)
++#define g4float_movhl(a,b) _mm_movehl_ps(a, b)
++#define g4float_emms _mm_empty
+
+
+ static INLINE long
+--
+cgit v0.9.0.2
diff --git a/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch b/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch
new file mode 100644
index 000000000000..4b6cf919a849
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch
@@ -0,0 +1,12 @@
+Index: babl-0.1.10/babl/Makefile.am
+===================================================================
+--- babl-0.1.10.orig/babl/Makefile.am
++++ babl-0.1.10/babl/Makefile.am
+@@ -95,6 +95,7 @@ INTROSPECTION_COMPILER_ARGS = --included
+ if HAVE_INTROSPECTION
+ Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am libbabl-@BABL_API_VERSION@.la
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
++ --identifier-prefix= --symbol-prefix=babl \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --library=$(builddir)/libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
diff --git a/media-libs/babl/files/babl-0.1.10-introspection.patch b/media-libs/babl/files/babl-0.1.10-introspection.patch
new file mode 100644
index 000000000000..f9b92698689d
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-introspection.patch
@@ -0,0 +1,25 @@
+From c024c89f95de4a8fa95ba96790dac61768d11a17 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Tue, 10 Jan 2012 16:32:50 +0000
+Subject: gobject-introspection: fix build of the .gir and .typelib files.
+
+---
+diff --git a/babl/Makefile.am b/babl/Makefile.am
+index cefab57..03115a3 100644
+--- a/babl/Makefile.am
++++ b/babl/Makefile.am
+@@ -93,10 +93,10 @@ INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
+ INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
+
+ if HAVE_INTROSPECTION
+-Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am
++Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am libbabl-@BABL_API_VERSION@.la
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
+ --add-include-path=$(srcdir) --add-include-path=. \
+- --library=babl-$(BABL_API_VERSION) \
++ --library=$(builddir)/libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
+ --output $@ \
+ -DBABL_IS_BEING_COMPILED \
+--
+cgit v0.9.1
diff --git a/media-libs/babl/metadata.xml b/media-libs/babl/metadata.xml
new file mode 100644
index 000000000000..392c18acea45
--- /dev/null
+++ b/media-libs/babl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>