summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-07 21:03:39 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-07 22:13:58 +0100
commitfda5981944688fa7d423374508d28fb1a2490cb9 (patch)
tree1dee37c86f84d7e49e794964f0459623e88acbc2 /media-libs/bcg729/bcg729-1.0.4.ebuild
parentnet-analyzer/dnstracer: Fix buffer overflow in host argument (bug #620928). (diff)
downloadgentoo-fda5981944688fa7d423374508d28fb1a2490cb9.tar.gz
gentoo-fda5981944688fa7d423374508d28fb1a2490cb9.tar.bz2
gentoo-fda5981944688fa7d423374508d28fb1a2490cb9.zip
media-libs/bcg729: Initial commit.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/bcg729/bcg729-1.0.4.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-1.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/bcg729/bcg729-1.0.4.ebuild b/media-libs/bcg729/bcg729-1.0.4.ebuild
new file mode 100644
index 000000000000..d5909b374475
--- /dev/null
+++ b/media-libs/bcg729/bcg729-1.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools ltprune
+
+DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
+HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+RDEPEND="
+ !media-plugins/mediastreamer-bcg729
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}