summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-25 13:02:15 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-26 06:59:10 -0500
commit1760e510c93da503d1694764bac6d4f695bb5ffe (patch)
treebb0b59928d93ba721725c2923699acdb2d3d2fb7 /media-libs/elementary/elementary-1.16.1.ebuild
parentdev-libs/efl: version bump to 1.16.1 (diff)
downloadgentoo-1760e510c93da503d1694764bac6d4f695bb5ffe.tar.gz
gentoo-1760e510c93da503d1694764bac6d4f695bb5ffe.tar.bz2
gentoo-1760e510c93da503d1694764bac6d4f695bb5ffe.zip
media-libs/elementary: version bump to 1.16.1
Diffstat (limited to 'media-libs/elementary/elementary-1.16.1.ebuild')
-rw-r--r--media-libs/elementary/elementary-1.16.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/elementary/elementary-1.16.1.ebuild b/media-libs/elementary/elementary-1.16.1.ebuild
new file mode 100644
index 000000000000..7cef5b066732
--- /dev/null
+++ b/media-libs/elementary/elementary-1.16.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
+HOMEPAGE="https://trac.enlightenment.org/e/wiki/Elementary"
+
+LICENSE="LGPL-2.1"
+IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
+
+DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug)
+ $(use_enable doc)
+ --disable-ecore-cocoa
+ --disable-ecore-psl1ght
+ --disable-ecore-win32
+ --disable-elocation
+ --disable-emap
+ --disable-eweather
+ # broken: make[4]: *** No rule to make target 'prefs_example_01.epb', needed by 'all-am'. Stop
+ #$(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X ecore-x)
+ $(use_enable quicklaunch quick-launch)
+ )
+
+ enlightenment_src_configure
+}