summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-25 08:21:01 +0000
committerSam James <sam@gentoo.org>2023-04-26 05:02:35 +0100
commitd4a533b6e778af224bf67f9a45c3fc065774c0e4 (patch)
tree1980bb045a745aae4206bbcc1183c4dc2e62fcbd /media-libs/exiftool/exiftool-12.61.ebuild
parentmedia-libs/exiftool: drop 12.59 (diff)
downloadgentoo-d4a533b6e778af224bf67f9a45c3fc065774c0e4.tar.gz
gentoo-d4a533b6e778af224bf67f9a45c3fc065774c0e4.tar.bz2
gentoo-d4a533b6e778af224bf67f9a45c3fc065774c0e4.zip
media-libs/exiftool: Add 12.61
New bugfix release. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/30746 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/exiftool/exiftool-12.61.ebuild')
-rw-r--r--media-libs/exiftool/exiftool-12.61.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/exiftool/exiftool-12.61.ebuild b/media-libs/exiftool/exiftool-12.61.ebuild
new file mode 100644
index 000000000000..4602af41803e
--- /dev/null
+++ b/media-libs/exiftool/exiftool-12.61.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ http://exiftool.sourceforge.net"
+SRC_URI="https://exiftool.org/${DIST_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}