summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-18 22:47:06 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-18 22:47:37 -0500
commit00d483b9e0a95a670bed0ec3b97e2adf16afb0c4 (patch)
treecf17171040dda5d1a6e65e0e7ee1ba4c1f9ce38b /media-libs/glfw/glfw-3.1.2.ebuild
parentprofiles: reduce app-emulation/wine gstreamer mask to 1.7.54 only (diff)
downloadgentoo-00d483b9e0a95a670bed0ec3b97e2adf16afb0c4.tar.gz
gentoo-00d483b9e0a95a670bed0ec3b97e2adf16afb0c4.tar.bz2
gentoo-00d483b9e0a95a670bed0ec3b97e2adf16afb0c4.zip
media-libs/glfw: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/glfw/glfw-3.1.2.ebuild')
-rw-r--r--media-libs/glfw/glfw-3.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/glfw/glfw-3.1.2.ebuild b/media-libs/glfw/glfw-3.1.2.ebuild
new file mode 100644
index 000000000000..1aa6935bcd78
--- /dev/null
+++ b/media-libs/glfw/glfw-3.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="http://www.glfw.org/"
+SRC_URI="mirror://sourceforge/glfw/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="egl examples"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ x11-libs/libXinerama
+ x11-libs/libXcursor
+ virtual/opengl"
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use egl GLFW_USE_EGL)
+ $(cmake-utils_use examples GLFW_BUILD_EXAMPLES)
+ -DBUILD_SHARED_LIBS=1
+ "
+ cmake-utils_src_configure
+}