summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-02-18 12:21:46 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-02-18 12:22:38 +0100
commitcace804f673d1d78a94e7244d66986853859ca22 (patch)
treee72515beba1fdbb4206cc686d86b54e391928fee /media-libs/glm
parentkde-apps/kross-interpreters: support for new ruby (diff)
downloadgentoo-cace804f673d1d78a94e7244d66986853859ca22.tar.gz
gentoo-cace804f673d1d78a94e7244d66986853859ca22.tar.bz2
gentoo-cace804f673d1d78a94e7244d66986853859ca22.zip
media-libs/glm: restore arm64 stable version
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'media-libs/glm')
-rw-r--r--media-libs/glm/Manifest1
-rw-r--r--media-libs/glm/glm-0.9.9.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/glm/Manifest b/media-libs/glm/Manifest
index 6b41fed3948c..f75ae6b2e52e 100644
--- a/media-libs/glm/Manifest
+++ b/media-libs/glm/Manifest
@@ -1 +1,2 @@
+DIST glm-0.9.9.5.tar.gz 4578601 BLAKE2B 9ce4dc7e638a651f958e2e0e1bfa0da121aefc382579838bfd810952bb8f4253e17caa6d743de713c86a4e8bd5f1afa38f8162e5f2d98ab141d94574d1103d40 SHA512 3b329acf5144aab1c0f47f8045d34e097699bd6685118ad8322c5ce23afdcb44ba2bb07e49301db06355b8eef7d4340b72251d55e113b533740d1e6ef6609911
DIST glm-0.9.9.7.tar.gz 4357077 BLAKE2B 59746a8775e0fc20fe8a8c3ae01c48841066d6092ce3cd7fa93bbf29f5247c42645bc920a3dbf3f0b4b61eb1e47f46514d9cd98c4e6df133ced0072ba6a570ee SHA512 9c557788d6382777317c94f8b30bc3df7e533877705514fa5d384f97b076d6bc750e841acbecdec8113e21af07bd8850159f5f1e079aaa2cde25540b480f983b
diff --git a/media-libs/glm/glm-0.9.9.5.ebuild b/media-libs/glm/glm-0.9.9.5.ebuild
new file mode 100644
index 000000000000..b439b0bf903d
--- /dev/null
+++ b/media-libs/glm/glm-0.9.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="OpenGL Mathematics"
+HOMEPAGE="http://glm.g-truc.net/"
+SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( HappyBunny MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm arm64 ~ppc64 ~x86"
+IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/opengl"
+
+src_configure() {
+ if use test; then
+ local mycmakeargs=(
+ -DGLM_TEST_ENABLE=ON
+ -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
+ )
+ fi
+
+ cmake-utils_src_configure
+}