summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-07 02:19:06 +0000
committerSam James <sam@gentoo.org>2025-01-07 02:22:45 +0000
commit3d9f9dc9cc7e78524deed6d0c39f1a99603eafa1 (patch)
tree00489739151fcf24c38e312b3bc6b0317501a261 /media-libs/gstreamer-editing-services
parentdev-python/gst-python: add 1.24.11 (diff)
downloadgentoo-3d9f9dc9cc7e78524deed6d0c39f1a99603eafa1.tar.gz
gentoo-3d9f9dc9cc7e78524deed6d0c39f1a99603eafa1.tar.bz2
gentoo-3d9f9dc9cc7e78524deed6d0c39f1a99603eafa1.zip
media-libs/gstreamer-editing-services: add 1.24.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gstreamer-editing-services')
-rw-r--r--media-libs/gstreamer-editing-services/Manifest1
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.24.11.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/gstreamer-editing-services/Manifest b/media-libs/gstreamer-editing-services/Manifest
index 37c93a2ea2aa..2c7cb8c938b5 100644
--- a/media-libs/gstreamer-editing-services/Manifest
+++ b/media-libs/gstreamer-editing-services/Manifest
@@ -1,3 +1,4 @@
DIST gst-editing-services-1.22.11.tar.xz 836008 BLAKE2B 49ce48e45b956f9675f64f8da4ce2a8cd851ccba5573e722d8f823ff08a96053a4b8beca14fe5d32b4d8f71abf32feba2c2b80c10cf3825c32a5eaf52ce474a4 SHA512 87f1240c3c18d1530ace3f15ad50acef90dab2808198658b5f9da54a5cfe2ee2c040e7bdd766550e566c5e86a1509b12a473b6063f3a7e471ee18b163b40873d
DIST gst-editing-services-1.22.12.tar.xz 836768 BLAKE2B 252426269ab9b7893bf688335ec8920203846f3211a37ccbbd5256104bcee44d3897986e8787ecc138cfb97402c69f27e1622a774f7ada5d0ae6ea07e0495204 SHA512 34a888ca63c883c55e27b5b7270c6842f03d45544fd698c60e35a640f978c60667a23baec096e4be73a618beffdbf251bcc310437a1f1122aa98c2dc7a0b301c
DIST gst-editing-services-1.24.10.tar.xz 854400 BLAKE2B 85ac071a608e6d21c9c72328851b70d046eef58c9c029d92c0f8e78673a36cf8c6d5b4c00f8b8dec2f801da989edbd9645b20b1961a5cdcc107e30493707bebf SHA512 864c6f03470288bdad2ab9d9c712bc471ae313bad58c08b83aca4b7959d71f7e026b55a8c125fae8abecc89bfb9717e0eaae5bce7c681a82cbd96f1f66684e64
+DIST gst-editing-services-1.24.11.tar.xz 855536 BLAKE2B 3273bb65ddbd23a98f1046a34b1fee28d4187e817662603ecd6fd723e1b9feada4ed478eb9d921062bc2b7f75c3fc04de3c306297f63dd77c85b5cc57d6e6903 SHA512 04535b53aa6120d944ad10beec717fc10a5241d62d3277922750a6523dc0f2e939b2eb4e87b8d7bed615c1920b9cc97e1a40bc25b5b5b7427251541904e4eaa8
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.24.11.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.24.11.ebuild
new file mode 100644
index 000000000000..e55b8864a59d
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.24.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-r1
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P/gstreamer/gst}.tar.xz"
+S="${WORKDIR}"/${P/gstreamer/gst}
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="+introspection test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Some tests are failing
+RESTRICT="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.40.0:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-bad-${PV}:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ python_setup
+
+ local emesonargs=(
+ -Ddoc=disabled # hotdoc not packaged
+ $(meson_feature introspection)
+ $(meson_feature test tests)
+ -Dbash-completion=disabled
+ -Dxptv=disabled
+ -Dpython=enabled
+ -Dvalidate=disabled
+ -Dexamples=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule bindings/python/gi/overrides/GES.py
+}