summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-31 00:11:56 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-31 00:17:23 +0200
commit346cb31537afca7b06a7663b6d65ab1458fc6be2 (patch)
tree5f3c47a23e9ee2a16993d261e0765b3ac29fc50b /media-libs/libheif
parentmedia-libs/libheif: fix subslot (diff)
downloadgentoo-346cb31537afca7b06a7663b6d65ab1458fc6be2.tar.gz
gentoo-346cb31537afca7b06a7663b6d65ab1458fc6be2.tar.bz2
gentoo-346cb31537afca7b06a7663b6d65ab1458fc6be2.zip
media-libs/libheif: bump to v1.8.0
Closes: https://github.com/gentoo/gentoo/pull/17294 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/libheif')
-rw-r--r--media-libs/libheif/Manifest1
-rw-r--r--media-libs/libheif/libheif-1.8.0.ebuild59
-rw-r--r--media-libs/libheif/libheif-9999.ebuild2
3 files changed, 61 insertions, 1 deletions
diff --git a/media-libs/libheif/Manifest b/media-libs/libheif/Manifest
index befd4776bec3..1361ad581938 100644
--- a/media-libs/libheif/Manifest
+++ b/media-libs/libheif/Manifest
@@ -2,3 +2,4 @@ DIST libheif-1.5.1.tar.gz 1510087 BLAKE2B 1dd5e913c8913c6b62b770653585f8ccf7cda1
DIST libheif-1.6.1.tar.gz 1514950 BLAKE2B d658f0c408f9a09eaac890119119327bd3e9c84db785d001b2c7a979b9574a6723403fe063ed6ce77812bface04be124e808fc90c1325c13e3d87f8b46ac0b65 SHA512 5a2104e529d59c23c988b6c0c167f9e7017ff77763eb71fee1c26f97624e9d7e2d0f863123d1886536d37f96ea6b93969a1c53e747672c54a2220aa6f47be1bf
DIST libheif-1.6.2.tar.gz 1515763 BLAKE2B e7a901394349bc8bbf633a0193d7a08a1cecf7e97a8ac709efb9c2e5e6da387c7fa5e8b551cecf1f67b4e7a7d06f034e64c20d7c55f9a7898c0badb79ed485f7 SHA512 41848c05d88f82827ebdd0662a1870ce8b7899f6a86ef5aa483b301176602da8e69d2c5a49b4d911bc0cac51bdab81a06fd43efae2722092cc09c02119c95f07
DIST libheif-1.7.0.tar.gz 1526096 BLAKE2B 74b8284875321781d13d17b877eb8291ecdd0fe1700f73a433d3b125a8ee6b33a326310d729e62bac9d9fecfea095f21ef590e711d550dcaac79570b3f917885 SHA512 13c95540fee13f3fba8d8a4f69886bf5563e9fa22c5cd113dbe16d20670b077b5961171e5f9fb0f256cc42c4650e13465c93d3fbb03013997a7fc163463e8b3a
+DIST libheif-1.8.0.tar.gz 1544438 BLAKE2B 983d3675c6788f69d7839d72064ca97d7347f5b2105b489ea6834c6ca5ab3d0ad8dd9157ab9d8636d3978a308d9f1983c8e5b0d151ffd9c013c9b2c9ef059d74 SHA512 e6edf03c0baf7d55ace57b8de1cf05d3b6708a0bd58d4191599960ad3924509dd7e9528a021586012b768a5a5b253e5bab470b944a2ead45f85274842da4913a
diff --git a/media-libs/libheif/libheif-1.8.0.ebuild b/media-libs/libheif/libheif-1.8.0.ebuild
new file mode 100644
index 000000000000..6c16fb0e9ab5
--- /dev/null
+++ b/media-libs/libheif/libheif-1.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.8"
+IUSE="gdk-pixbuf go static-libs test +threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ go? ( dev-lang/go )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' configure.ac || die
+
+ eautoreconf
+
+ # prevent "stat heif-test.go: no such file or directory"
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local econf_args=(
+ $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(use_enable gdk-pixbuf)
+ $(use_enable static-libs static)
+ $(use_enable threads multithreading)
+ )
+ ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index b8162330b128..6c16fb0e9ab5 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -17,7 +17,7 @@ DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
-SLOT="0/1.7"
+SLOT="0/1.8"
IUSE="gdk-pixbuf go static-libs test +threads"
RESTRICT="!test? ( test )"