summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-08 00:24:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-08 00:25:40 +0100
commit0d6d9e58edf4d2310914e03de3791dde3ff7778b (patch)
treeed54dfdbe91f5291b203c0964ca25447321e9626 /media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
parentnet-analyzer/rrdtool: migrate to lua.eclass (diff)
downloadgentoo-0d6d9e58edf4d2310914e03de3791dde3ff7778b.tar.gz
gentoo-0d6d9e58edf4d2310914e03de3791dde3ff7778b.tar.bz2
gentoo-0d6d9e58edf4d2310914e03de3791dde3ff7778b.zip
media-libs/liblastfm: 1.1.0_pre20190625 snapshot bump
Basically just incorporating the patches we already apply to prev snapshot. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild')
-rw-r--r--media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild b/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
new file mode 100644
index 000000000000..66923fd858eb
--- /dev/null
+++ b/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=f867df52757c569d97d9755c911ac9dec146f365
+inherit cmake
+
+DESCRIPTION="Collection of libraries to integrate Last.fm services"
+HOMEPAGE="https://github.com/lastfm/liblastfm"
+SRC_URI="https://github.com/lastfm/liblastfm/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+SLOT="0/0"
+IUSE="fingerprint test"
+
+# 1 of 2 (UrlBuilderTest) is failing, last checked version 1.0.9
+RESTRICT="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ fingerprint? (
+ dev-qt/qtsql:5
+ media-libs/libsamplerate
+ sci-libs/fftw:3.0
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ # demos not working
+ local mycmakeargs=(
+ -DBUILD_DEMOS=OFF
+ -DBUILD_WITH_QT4=OFF
+ -DBUILD_FINGERPRINT=$(usex fingerprint)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}