summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-09 17:10:37 +0100
committerSam James <sam@gentoo.org>2023-05-09 18:46:18 +0100
commit783445eef1047f5a0a5386fc68d45030a8eb7735 (patch)
tree5f09f13998eb793530f180adc0009e8ee125f55b /media-libs/liblo
parentapp-arch/zchunk: conditionally build tests (diff)
downloadgentoo-783445eef1047f5a0a5386fc68d45030a8eb7735.tar.gz
gentoo-783445eef1047f5a0a5386fc68d45030a8eb7735.tar.bz2
gentoo-783445eef1047f5a0a5386fc68d45030a8eb7735.zip
media-libs/liblo: conditionally build tests & unrestrict them
They pass for me now, I assume the network tests are why they were restricted... Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/liblo')
-rw-r--r--media-libs/liblo/files/liblo-0.31-werror.patch11
-rw-r--r--media-libs/liblo/liblo-0.31.ebuild16
2 files changed, 22 insertions, 5 deletions
diff --git a/media-libs/liblo/files/liblo-0.31-werror.patch b/media-libs/liblo/files/liblo-0.31-werror.patch
new file mode 100644
index 000000000000..84ea528ba8a4
--- /dev/null
+++ b/media-libs/liblo/files/liblo-0.31-werror.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -172,7 +172,7 @@ if test "x$want_threads" = "xyes"; then
+ fi
+
+ # Add back -Werror if it was there before
+-CFLAGS="$CFLAGS""$CFLAGS_werror"
++CFLAGS="$CFLAGS"
+
+ # Optional threads support
+ THREADS_ENABLER='#include "lo/lo_serverthread.h"'
diff --git a/media-libs/liblo/liblo-0.31.ebuild b/media-libs/liblo/liblo-0.31.ebuild
index feff8bb7ffce..aa10a338013d 100644
--- a/media-libs/liblo/liblo-0.31.ebuild
+++ b/media-libs/liblo/liblo-0.31.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
@@ -11,12 +12,15 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~ppc-macos"
-IUSE="doc ipv6 static-libs"
-
-RESTRICT="test"
+IUSE="doc ipv6 static-libs test"
+RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.31-werror.patch
+)
+
src_prepare() {
default
@@ -30,8 +34,10 @@ src_configure() {
use doc || export ac_cv_prog_HAVE_DOXYGEN=false
# switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
- myeconfargs=(
+ local myeconfargs=(
--enable-threads
+ --disable-network-tests
+ $(use_enable test tests)
$(use_enable ipv6)
$(use_enable static-libs static)
)