summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:40:04 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:21 +0300
commit650f0f6b31812da92f158734e7833a739f303741 (patch)
treebe0c244529ed888fc85929bebead97fd50e37fe2 /media-libs/libmatemixer
parentmedia-libs/libmatemixer: drop 1.27.0 (diff)
downloadgentoo-650f0f6b31812da92f158734e7833a739f303741.tar.gz
gentoo-650f0f6b31812da92f158734e7833a739f303741.tar.bz2
gentoo-650f0f6b31812da92f158734e7833a739f303741.zip
media-libs/libmatemixer: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'media-libs/libmatemixer')
-rw-r--r--media-libs/libmatemixer/Manifest1
-rw-r--r--media-libs/libmatemixer/libmatemixer-1.28.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libmatemixer/Manifest b/media-libs/libmatemixer/Manifest
index 6b954775c9e6..d647b8833b44 100644
--- a/media-libs/libmatemixer/Manifest
+++ b/media-libs/libmatemixer/Manifest
@@ -1 +1,2 @@
DIST libmatemixer-1.26.1.tar.xz 497560 BLAKE2B a84922fa8743749e0120845a462de84d2057049957207357e4212a1e6201c60bd31b873282764ec2e2380e3a0c76dd498deaef32bdefb9f012b141d9adad280f SHA512 a67a63bbf76b69ba78a537f7690230f45c5875b4358991e73604aacf001baa40ee994101d486218be8000be43be6561b6f25f4f38ae00310c5a08affb6dafbdb
+DIST libmatemixer-1.28.0.tar.xz 497120 BLAKE2B 8f747bfe304082caea08b7443ba3b3170b8dcaf049dd8c3eabe2eb3124007e9c80b17d400ea8bb522031309f3428674e4a50ca7ad15939ad9a47fe82a09d3a41 SHA512 9bfe33a851eae10564ccad5d578a76c565cba1d8c720b89eb1105c8d507436b31d6d0c9c1112dbf6b8cc7def97f14ff19feb6f55d6cf8de2d0421b5cf1dfc485
diff --git a/media-libs/libmatemixer/libmatemixer-1.28.0.ebuild b/media-libs/libmatemixer/libmatemixer-1.28.0.ebuild
new file mode 100644
index 000000000000..182ecdfb2237
--- /dev/null
+++ b/media-libs/libmatemixer/libmatemixer-1.28.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Mixer library for MATE Desktop"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+alsa pulseaudio +udev"
+REQUIRED_USE="udev? ( alsa )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )
+ pulseaudio? ( media-libs/libpulse[glib] )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig
+"
+
+RDEPEND="${COMMON_DEPEND}
+ alsa? ( udev? ( virtual/libudev:= ) )
+"
+
+DEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mate_src_configure \
+ --disable-null \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio)
+}